Hi - 
I'm having kernel version 2.6.32.26-175.fc12.x86_64  and download version 2.6.32 created a uml kernel but it modules are named as "2.6.32-gdea2244-dirty". Thus I can't insert custom modules created from 2.6.32.26-175.fc12.x86_64 kernel.

since i read somewhere host kernel > downloladed kernel . Then downloaded 2.6.35  I have tried different versions (for more than 8 hrs now) 2.6.31 - in all cases uml modules are 2.6.35-gdea2244-dirty 2.6.31-gdea2244-dirty

I have module built which as vermagic as "2.6.35" but I can't load that module into uml. because of version mismatch

#modinfo fs/binfmt_misc.ko 
filename:       fs/binfmt_misc.ko
license:        GPL
depends:        
vermagic:       2.6.35-gdea2244-dirty mod_unload 

Why this "-gdea2244-dirty" gets appended to modules? Now I'm completely stuck ,looking for help.

-- 
----
Cheers,
Lakshmipathi.G
FOSS Programmer.