Can you try 2.6.20 from kernel.org?  Looks like a Ubuntu kernel patch is
breaking UML.

Yes it was an old grsecurity patch that I totally forgot. Sorry for the question; it works fine without.

Thanks again.