It appears to me that the kernel tree will not build with the 2.6.16-rc4 patch set I downloaded today, if HAVE_AIO_ABI is not defined. 

finish_aio_26() is referenced in arch/um/os-Linux/aio.c, but is not defined.  It looks like a stub was omitted.

Sorry for the mistaken posting to the user list.

  --  John