The problem was is my /tmp mounted with noexec, this caused UML to sigfualt, I found a workaround for this, without remounting /tmp with exec, is that create /tmp2, and run linux kernel as below:

TMPDIR=/tmp2 ./linux *** Write your parameters here ***

Ali Almahdi wrote:
I wasn't able to boot UML on my new server, I have tried most uml patches and kernel versions with no success..


# ./linux
Checking for the skas3 patch in the host...found
Checking for /proc/mm...found
Linux version 2.6.8.1-1um (root@localhost) (gcc version 3.3.2 20031022 (Red Hat Linux 3.3.2-1)) #1 Fri Aug 27 10:02:17 AST 2004
Built 1 zonelists
Kernel command line: root=98:0
PID hash table entries: 16 (order 4: 128 bytes)
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Memory: 27616k available
Calibrating delay loop... 3971.48 BogoMIPS
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
Checking for host processor cmov support...Yes
Checking for host processor xmm support...No
Checking that ptrace can change system call numbers...OK
Checking that host ptys support output SIGIO...Yes
Checking that host ptys support SIGIO on close...No, enabling workaround
Checking for /dev/anon on the host...Not available (open failed with errno 2)
NET: Registered protocol family 16
SCSI subsystem initialized
mconsole (version 2) initialized on /root/.uml/u0qnZB/mconsole
UML Watchdog Timer
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Coda Kernel/Venus communications, v6.0.0, coda@cs.cmu.edu
devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x0
Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
udf: registering filesystem
Kernel panic: map_memory(0x42800000, 3, 0xce7000, 4096, 1, 1, 1) failed, err = -1

<6>SysRq : Show Regs

EIP: 0073:[<4026c7a1>] CPU: 0 Not tainted ESP: 007b:4046cfa0 EFLAGS: 00000216
   Not tainted
EAX: 00000000 EBX: 00007f09 ECX: 00000013 EDX: 00007f09
ESI: 00000000 EDI: 00000000 EBP: 00000000 DS: 007b ES: 007b
Call Trace: [<40165170>] [<4001a0aa>] [<4003cc66>] [<40030676>] [<400306df>]
  [<40014979>] [<4001eab4>] [<4001eafc>] [<40017823>] [<40019591>] [<4026c827>]
  [<40017883>] [<400198c4>] [<4026c7a1>] [<40019833>] [<4001ec10>] [<4001ec29>]
  [<400199b2>] [<4026c827>] [<4026c558>] [<40144800>] [<4026c827>] [<4026c827>]
  [<400179c8>] [<4026c827>] [<400179c8>] [<4026c827>] [<400179c8>] [<400148cd>]
  [<4005a97a>] [<4005aa31>] [<4005aa0f>] [<4005ab04>] [<4005aeee>] [<4005af46>]
  [<401447cd>] [<40049ffe>] [<40048ecc>] [<40007cc3>] [<40002604>] [<4000f5a0>]
  [<4000f5c7>] [<4000f5a0>] [<4001504d>] [<4000f5a0>] [<40015028>] [<400178ca>]
  [<4002d7d0>] [<4000f5a0>] [<4002d821>] [<4000f5a0>] [<4001e34a>] [<4000f5a0>]
  [<4026c558>] [<4026c7a1>]
Segmentation fault (core dumped)



My server is running on P4, 2GB RAM

My UML config is attached.

Thanks alot,
Ali