Thanks a lot. It's OK by now.

-----Original Message-----
From: Jan Hudec <bulb@ucw.cz>
To: BALU Frédéric <frederic.balu@cegetel.fr>
CC: 'user-mode-linux-user@lists.sourceforge.net' <user-mode-linux-user@lists.sourceforge.net>
Sent: Tue Oct 28 15:36:58 2003
Subject: Re: [uml-user] tuntap_open_tramp failed - errno=22

On Tue, Oct 28, 2003 at 15:24:40 +0100, BALU Frédéric wrote:
> uml_net is in /usr/lib/uml.
> uml_net is -rwsrwxrwx. I'm loged as root.
> my PATH includes /usr/lib/uml ; the error "Exec of 'uml_net' failed - errno
> = 2" remains the same.

IIRC you get the same error when there is a linker error. Try actualy
executing it from the shell. You should see:

uml_net : bad argument list - if you're running uml_net by
hand, don't bother.  uml_net is run automatically by UML when
necessary.

If you do and it still does not work, it will probably be time to look
at the code, why this might actualy happen.

> -----Original Message-----
> From: Jan Hudec [mailto:bulb@ucw.cz]
> Sent: Tuesday, October 28, 2003 3:15 PM
> To: BALU Frédéric
> Cc: 'user-mode-linux-user@lists.sourceforge.net'
> Subject: Re: [uml-user] tuntap_open_tramp failed - errno=22
>
>
> On Tue, Oct 28, 2003 at 14:48:23 +0100, BALU Frédéric wrote:
> > Hello everybody,
> >
> >  I encounter a eth/tap problem with the following configuration :
> >   - pentium I - 200 MHz
> >   - 2 * 3COM 3c59x Ethernet card
> >   - Debian woody
> >   - kernel 2.4.18-bf24
> >   - UML 2.4.18-13um home compiled
> >  dmesg says :
> >   Universal TUN/TAP device driver 1.4
> >   Netdevice 0 :TUN/TAP device backend-IP=192.168.3.254
> >   Netdevice 1 :TUN/TAP device backend-IP=192.168.4.254
> >  ifconfig - a :
> >   eth0 : Eth@ OK ; no IP@ ; BROADCAST MULTICAST
> >   eth1 : Eth@ OK ; no IP@ ; BROADCAST MULTICAST
> >   The IP@ is visible with ifconfig -a only if I do a ifconfig ethx down
> >  /dev :
> >    tap0 is there (are minor(16) & major(36) correct ?)
> >
> >  PROBLEM :
> >   ifconfig ethx up issues :
> >    tuntap_open_tramp : didn't receive a message
> >    Exec of 'uml_net' failed - errno = 2
>
> 2 => No such file or directory
>
> uml_net not exectuable or not found. Try seting PATH (uml_net usualy
> lives in /usr/lib/uml, which is not commonly found in PATH).
>
> >    tuntap_open_tramp failed - errno = 22
> >    SIOCSIFFLAGS: Invalid argument
>
> Just a result of the error above.
>
> ----------------------------------------------------------------------------
> ---
>                                                Jan 'Bulb' Hudec
> <bulb@ucw.cz>
-------------------------------------------------------------------------------
                                                 Jan 'Bulb' Hudec <bulb@ucw.cz>