I have just compiled a 2.4.24 kernel with ow1 (openwall security fixes) skas and dev-anon patch as well as I just patched it with for the host kernel.
which compiled just fine and is loaded.
the uml kernel however doesn't seem to be compiling. I decded to use gcc-3.0 to compile the host 2.4.24 and I tryed that as well with the uml kernel which is 2.4.24
I've tried both gcc3 and gcc2-95 on the uml kernel as it still gives me errors on compileing.
In file included from process.c:27:
/root/linux-2.4.24/arch/um/include/skas_ptrace.h:9: redefinition of `struct ptrace_faultinfo'
/root/linux-2.4.24/arch/um/include/skas_ptrace.h:14: redefinition of `struct ptrace_ldt'
make[3]: *** [process.o] Error 1
make[3]: Leaving directory `/root/linux-2.4.24/arch/um/kernel/skas'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/root/linux-2.4.24/arch/um/kernel/skas'
make[1]: *** [_subdir_skas] Error 2
make[1]: Leaving directory `/root/linux-2.4.24/arch/um/kernel'
make: *** [_dir_arch/um/kernel] Error 2
while using gcc3.0 it gives me the same error.
Thanks for any help
Douglas Wheet