Hi all

 

I have start my UML’s in the following manner:

 

screen –S <name> -d –m su - <user. –c “TMPIR=<tmpfs mounted path> linux-2.4.27  mem=<196M> \

uml_dir <some other tmp location> ubd0s=<uml_fs> ubd1s swap_fs umid=<name> eht0=tuntap,tapx,,<host ip>

 


This all works fine except uml_mconsole appears to misbehave.

 

If I run uml_mconsole <name> from the host logged in as root, i.e not the user of the UML in question,  I get this:

 

uml_mcosole <name>

Warning: couldn’t stat /root/.uml/<name>/mconsole – No such file or directory

Warning: couldn’t stat /tmp/uml/<name>/mconsole – No such file or directory

(none)

 

Both warnings are correct.  However, the mconsole and pid files are actually on the <some other tmp location> at stated in my uml_dir parameter above.

 

If I then run

uml_mcosole /<some other tmp location>/<name>  if get this:

 

Warning: couldn’t stat /root/.uml//< some other tmp location >/<name>/mconsole – No such file or directory

….etc

 

The above only works if:

1. I run uml_mconsole ../../ <some other tmp location>/<name>   using a relative paths instead of absolute

2. I start the UML as root or su to the user prior to start the UML’s (then screen fails – another story)

3. I set uml_dir to /tmp/uml

 

Does uml_mconsole not recognize uml_dir other than /tmp/uml ?

 

Thanks

Gerhard