USBIP client for windows XP not working

Help
Jeswin
2009-08-25
2013-05-30
  • Jeswin
    Jeswin
    2009-08-25

    My server IP is, 192.168.1.3. I have started usbipd from one terminal of 192.168.1.3

                   [root@localhost ~]# usbipd                                          
                   listen at [0.0.0.0]:3240
                   usbipd start (usbip 0.1.7 ($Id: stub_server.c 42 2007-09-07 12:07:51Z hirofuchi $))

    Opened another terminal of 192.168.1.3 and ran usbip -l 192.168.1.3 and got the following response.

                   [root@localhost ~]# usbip -l 192.168.1.3
                   - 192.168.1.3
                        8-1: Plantronics, Inc. : unknown product (047f:da41)
                           : /sys/devices/pci0000:00/0000:00:1d.2/usb8/8-1
                           : (Defined at Interface level) (00/00/00)
                           :  0 - Audio / Control Device / unknown protocol (01/01/00)
                           :  1 - Audio / Streaming / unknown protocol (01/02/00)
                           :  2 - Audio / Streaming / unknown protocol (01/02/00)
                           :  3 - Human Interface Devices / No Subclass / None (03/00/00)

    From my windows XP client, I started usbip.exe -l 192.168.1.3. it was showing failed.

                   usbip.exe -l 192.168.1.3
                   usbip dbg: usbip_network.c: 229 (tcp_connect ) trying 192.168.1.3 port 3240
                   usbip dbg: usbip_network.c: 255 (tcp_connect ) 192.168.1.3:3240, no destination to connect to
                   - 192.168.1.3 failed

    Please help me.