UPM on iMac OS X 10.9.1

Joe Chop
2014-01-29
2014-02-24
  • Joe Chop
    Joe Chop
    2014-01-29

    I deleted the script to execute UPM upon startup in my imac user file. Can anyone help me restore this capability?

     
  • Adrian Smith
    Adrian Smith
    2014-01-29

    Just reinstall UPM Joe. Your password database isn't stored alongside the app so you won't lose anything.

     
  • Joe Chop
    Joe Chop
    2014-01-29

    Thanks Adrian - I have tried downloading upm-mac-11_12_tar.gz from the sourceforge site and a mirror site a few times with negative results on each occurence. It downloads fine and unzips. When I double click on the app file I get an error that indicates 'UPM is damaged & can't be opened. You should move it to trash'. Even if I cancel out of that error screen, I'm unable to use the file. I get a damaged or modified error. I recently installed Mac OS X 10.9.1. All was working fine for UPM with the new OS until I deleted the start up routine in my mac user file in an effort to improve performance (it dipped slightly after the new OS was loaded - old processor with only 4M of RAM).

    Thanks for your help.

     
  • I have also not been able to get 11 or 12 to run, while 9 seems fine. I also am getting that error about a damaged file. It seems as though there might be a bad executable in the zip for those two version?

     
  • Adrian Smith
    Adrian Smith
    2014-02-23

    The problem is likely OS X's security settings. Try this,

    1. Open System Preferences
    2. Open Security & Privacy
    3. If the lock in the bottom left of this window is closed click it to unlock the settings
    4. Under "Allow applications downloaded from" select "Anywhere"
    5. Try opening the version of UPM that was failing previously. If all goes well it should work now.

    You can reset "Allow applications downloaded from" to what it was previously. OS X will remember that it's safe to open UPM.

     
  • That is strange, since I was not getting the usual warning about not trusted applications, but it did work. Thanks.
    However, there is now a problem with the new version. If I manually select "open" I can open an existing database. But, if I put in that same database in "Options->Database to Load On Startup" and then click OK, I get an error: "Invalid value for "minutes"". And the pref. for a particular database to open at default has gone away from 0.9 to .12. In other word if I open .9 it still shows that database, but .12 opens with no database showing, and if I try to set one it shows the above error. But, if I just select "open" it works fine.

     
  • Thanks. That work around was successful. It wasn't obvious that the error didn't relate to the database itself.