#576 With NOBATCH long running jobs skip the RUNNING state

UNICORE6.5
closed-fixed
TSI (15)
5
2012-08-28
2012-08-21
Shahbaz Memon
No

In my NO-BATCH TSI deployments, I see that a job that takes more execution time skips any transition to the Running state. During the execution phase it continuously returns the QUEUED state until the STAGINGOUT/SUCCESSFUL state is reached. It means except Running it doesn't miss other states STARTED / STAGINGIN / STAGINGOUT / SUCCESSFUL.

This behavior is not observed while running the same job on a Embedded or batch-TSI deployments.

As an example I am submitting a "dd" job that generates a big file of size ~5-10 GB. For reference the sample jsdl instance is attached under. Of course data staging target needs to be adjusted to your path. By the way I see the same behavior while submitting long sleep jobs.

Discussion

  • Shahbaz Memon
    Shahbaz Memon
    2012-08-21

    dd jsdl instance

     
    Attachments
  • Bernd Schuller
    Bernd Schuller
    2012-08-22

    • status: open --> closed-fixed
     
  • Bernd Schuller
    Bernd Schuller
    2012-08-27

    apparently not yet fixed

     
  • Bernd Schuller
    Bernd Schuller
    2012-08-27

    • status: closed-fixed --> open-accepted
     
  • Bernd Schuller
    Bernd Schuller
    2012-08-28

    • status: open-accepted --> closed-fixed
     
  • Bernd Schuller
    Bernd Schuller
    2012-08-28

    sorry, but using the trunk version of the NOBATCH tsi I can't reproduce it.