Huawei E169G

techpro
2008-05-12
2013-04-15
  • techpro
    techpro
    2008-05-12

    I discovered umtsmon while looking for a GUI app that will work with my Huawei E169G USB modem from 3 UK. I downloaded the precompiled binary dated 11/3/2008. I know that this device is not listed as supported but quite a bit works, which is encouraging.

    I can scan for mobile networks and they are listed correctly, but when I click Select the progress bar slowly proceeds from 1 to 100% and there is no change to the display afterwards.

    I can send an SMS successfully.

    The information option correctly gets the IMEI, model no. etc from the device.

    I have created a profile with APN, username and password that work with wvdial, and made it active. When I click Connect, there is an error in PPP that says:

    "/usr/sbin/pppd: The remote system is required to authenticate itself
    /usr/sbin/pppd: but I couldn't find any suitable secret (password) for it to use to do so.
    /usr/sbin/pppd: (None of the available passwords would let it use an IP address.)"

    What do I need to do to get this working?

     
    • techpro
      techpro
      2008-05-13

      I have got it working! I suspected that the error reported was not related to the hardware. A bit more Googling and I found that the solution was to comment out the "auth" line in etc/ppp/options, although there was a comment directly above it that warned me not to do this. Nevertheless I did, and I am now posting this message while connected using this USB modem!

      For some reason the signal strength is showing as n/a and the operator as 23420. The 3G signal is weak here and I was first connected using GPRS which was showing full signal strength.

      One thing where the E169G may need a bit of software support. If I understand it correctly, UMTSmon is supposed to be capable of handling dual-mode "ZeroCD" devices. The E169G is one such device but when I plugged it in at first it was not detected. I had to run usb_modeswitch to disable the CD-Rom and enable the Huawei mode. The commands that I used to do this were:

      usb_modeswitch -v 0x12d1 -p 0x1001 -d 1
      usb_modeswitch -v 0x12d1 -p 0x1001 -H 1

      I hope that will help you to add full support for this device. If there is anything else I can do to help or test any code, let me know.

       
      • Klaas van Gend
        Klaas van Gend
        2008-06-10

        I added the Huawei E169G with the 12d1-1001 IDs to the list of devices to run a zerocd switcher for.

        I'm afraid that won't solve your problem yet, as this is not really functioning yet :-(

         
    • foxof
      foxof
      2008-05-14

      Hi techpro,

      where did you get these figures for the modeswitch from. I have a problem with my Huawei E220. When starting umtsmon (in terminal mode) a window pops up questioning to switch the ZeroCD device. Both yes and no let umtsmon terminate. (See also "umtsmon does'nt work, Huawei E220 (Mobily/SA)" in Open Forum)

      regards
      foxof

       
    • techpro
      techpro
      2008-05-14

      I got that info from a blog posting describing how to get the E169G working on an Asus Eee PC: http://dalelane.co.uk/blog/?p=254 . The product code for the E220 is 0x1003. You could try that in the two commands where I use 0x1001.

      For the E220 you could also try running the program huaweiAktBBo. You can download the source code for it (one C file) from here: http://www.kanoistika.sk/bobovsky/archiv/umts/ . I notice that the distros I'm using have rules that are supposed to run this program when the device is plugged in. I tried modifying it to work with my device and it does work, but only when run manually for some reason.