#197 Ubuntu libavutil version not yet supported.

USDX 1.1
open
5
2014-04-29
2011-08-07
Anonymous
No

Trying to compile on Ubuntu 11.10 Alpha 3. I also tried running ./configure libavutil_VERSION=50.4.0 but it is still not yet supported. Anything lower than 49.0.1 is too old and anything higher, too new!!!

/ultrastardx/src/lib/ffmpeg/avutil.pas(115,4) Error: User defined: Linked version of libavutil is not yet supported!
/home/**/ultrastardx/src/lib/ffmpeg/avutil.pas(490,1) Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted
Error: /usr/bin/ppcx64 returned an error exitcode (normal if you did not specify a source file to be compiled)
make[1]:
[../game/ultrastardx] Error 1

Discussion

1 2 > >> (Page 1 of 2)

  • Anonymous
    2012-10-07

    Failing on openSUSE 12.2 as well, ffmpeg is too recent.

     
  • Solbu
    Solbu
    2013-01-19

    Same on the soon to come Mageia 3. ffmpeg version is not old enough.

     
  • Can you give the versions of ffmpeg or the ones for its libs (libavutil, libavformat, libavcodec, libswscale, ...)

     
  • Solbu
    Solbu
    2013-01-20

    (Trying again, please delete the anonymous post.)
    On mageia 3 (Cauldron) I have this:
    ===
    $ ffmpeg -version
    ffmpeg version 1.1
    built on Jan 8 2013 03:52:24 with gcc 4.7.2 (GCC)
    <snipp>
    libavutil 52. 13.100 / 52. 13.100
    libavcodec 54. 86.100 / 54. 86.100
    libavformat 54. 59.106 / 54. 59.106
    libavdevice 54. 3.102 / 54. 3.102
    libavfilter 3. 32.100 / 3. 32.100
    libswscale 2. 1.103 / 2. 1.103
    libswresample 0. 17.102 / 0. 17.102
    libpostproc 52. 2.100 / 52. 2.100
    ===

     
    Last edit: Solbu 2013-01-20
  • version 1.1 of ffmpeg is not yet supported. Can you try a version in the range 0.8-0.11?

     

  • Anonymous
    2013-06-03

    I am trying to package USDX for fedora. But I can only choose between ffmpeg-0.6 and ffmpeg-1.0.

    Are there any plans to port USDX to ffmpeg 1.x?

     
  • That is very unfortunate. There are plans for 1.0 and up, but that requires quite some work and will not happen in the near future.

     

  • Anonymous
    2013-07-15

    I have the same problem on RHEL, and my version is 10.7


    ultrastardx-1.1-src]$ ffmpeg -version
    ffmpeg version 0.10.7
    built on May 19 2013 18:47:10 with gcc 4.4.7 20120313 (Red Hat 4.4.7-3)
    configuration: --prefix=/usr --bindir=/usr/bin --datadir=/usr/share/ffmpeg --incdir=/usr/include/ffmpeg --libdir=/usr/lib64 --mandir=/usr/share/man --arch=x86_64 --extra-cflags='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic' --enable-bzlib --disable-crystalhd --enable-gnutls --enable-libass --enable-libcdio --enable-libcelt --enable-libdc1394 --disable-indev=jack --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-openal --enable-libopenjpeg --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libv4l2 --enable-libx264 --enable-libxvid --enable-x11grab --enable-avfilter --enable-postproc --enable-pthreads --disable-static --enable-shared --enable-gpl --disable-debug --disable-stripping --shlibdir=/usr/lib64 --enable-runtime-cpudetect
    libavutil 51. 35.100 / 51. 35.100
    libavcodec 53. 61.100 / 53. 61.100
    libavformat 53. 32.100 / 53. 32.100
    libavdevice 53. 4.100 / 53. 4.100
    libavfilter 2. 61.100 / 2. 61.100
    libswscale 2. 1.100 / 2. 1.100
    libswresample 0. 6.100 / 0. 6.100
    libpostproc 52. 0.100 / 52. 0.100


     
  • 0.10.7 should actually be supported. Probably tweaking the configure script is all what is needed. It will need not much dedication for fix it. Can you try? I am very busy for the next month.

     
  • Update: version 1.0 and 1.2 of ffmpeg work now. version 1.1 may still need some fixes. Please try and report.

    MiSchi.

     
1 2 > >> (Page 1 of 2)


Anonymous


Cancel   Add attachments