Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#9 a working demo song

closed
nobody
None
5
2007-10-27
2007-10-11
Michal Suchanek
No

When I select any song from the list USNG just keeps sitting there until I hit ESC.

If I am supposed to do something then it is not obvious what it is.

Discussion

  • Yoda-JM
    Yoda-JM
    2007-10-11

    Logged In: YES
    user_id=1319653
    Originator: NO

    Did you re-reun autogen.sh to regenerate configure script (from configure.in).
    If you do so, the configure script should have failed.

    Vincent

     
  • Yoda-JM
    Yoda-JM
    2007-10-11

    Logged In: YES
    user_id=1319653
    Originator: NO

    Sorry, wrong bug.
    What is the audio API you use (gstreamer or xine) ?
    What is the audio format you try to play ?
    If you use gstreamer and try to play a mp3 song, please be aware that you should install the plugin gst-mad (gst relies on plugin to play different format).

    Vincent

     
  • Logged In: YES
    user_id=404997
    Originator: YES

    well I am not sure I actually have any correct song. The demo song does not work, nor did the few I tried from the bunch I downloaded from the web.

    I see that the demo song does not have an audio file which bothers me a bit. I can imagine the program *could* work to some extent without one but I have no idea if it in fact would.

    It's probably gstreamer if it's the default. I did not specify which one should be used.

    I wonder why different audio library is needed for playback and different for capturing.

    And I hate gstreamer. It has zillion packages that always creep into the system as dependencies and it provides no functionality anyway.

     
  • Yoda-JM
    Yoda-JM
    2007-10-20

    Logged In: YES
    user_id=1319653
    Originator: NO

    Hi,

    could you try with xine audio backend or installing gst-bad plugins (the one that provides mp3 support).

    Vincent

     
  • Logged In: YES
    user_id=404997
    Originator: YES

    It looks like the problem is in the demo song. It does not have any mp3 file at all so it won't play no matter what output I compile.

    However, I have downloaded a few songs from different sites. One of them states it has a song with a background video. That song has all the necessary media files, and works.

     
  • Yoda-JM
    Yoda-JM
    2007-10-25

    Logged In: YES
    user_id=1319653
    Originator: NO

    Hi,

    The game does not provide any demo song (txt file is just an old relica).
    I'll close this bug as soon as the sf.net auth works again.

    Thanks for feedbacking

    Vincent

     
  • Yoda-JM
    Yoda-JM
    2007-10-27

    • status: open --> closed