Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#8 does not build

closed-fixed
nobody
None
5
2007-10-11
2007-10-04
Michal Suchanek
No

For me the current cvs does not build

make[2]: Entering directory `/home/hramrach/UltraStar-ng/src'
g++ -DHAVE_CONFIG_H -I. -I.. -I../include -I../audio -O2 -Wall -Wextra -Wshadow -I/usr/include/cairo -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/libxml2 -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/include/librsvg-2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-2.0 -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12 -DTHEMES_DIR="\"/home/hramrach/UltraStar/share/ultrastar-ng/themes/\"" -DDATA_DIR="\"/home/hramrach/UltraStar/share/ultrastar-ng/\"" -W -Wall -MT main.o -MD -MP -MF .deps/main.Tpo -c -o main.o main.cpp
main.cpp:11:37: error: boost/program_options.hpp: No such file or directory
../audio/audio.hpp: In constructor ‘da::pcm_data::pcm_data(da::sample_t*, size_t, size_t)’:
../audio/audio.hpp:33: warning: declaration of ‘channels’ shadows a member of 'this'
../audio/audio.hpp:33: warning: declaration of ‘frames’ shadows a member of 'this'
../audio/audio.hpp:33: warning: declaration of ‘buf’ shadows a member of 'this'
../audio/audio.hpp: In constructor ‘da::pcm_data::iter_by_ch::iter_by_ch(float*, size_t, size_t)’:
../audio/audio.hpp:41: warning: declaration of ‘channels’ shadows a member of 'this'
../audio/audio.hpp:41: warning: declaration of ‘buf’ shadows a member of 'this'
main.cpp: In function ‘int main(int, char**)’:
main.cpp:62: error: expected primary-expression before ‘namespace’
main.cpp:62: error: expected `;' before ‘namespace’
main.cpp:63: error: ‘po’ has not been declared
main.cpp:63: error: expected `;' before ‘desc’
main.cpp:64: error: ‘desc’ was not declared in this scope
main.cpp:66: error: ‘po’ has not been declared
main.cpp:66: error: expected primary-expression before ‘>’ token
main.cpp:66: error: ‘struct std::string’ has no member named ‘default_value’

gcc (GCC) 4.1.3 20070812 (prerelease) (Debian 4.1.2-15)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Discussion

  • Logged In: NO

    main.cpp:11:37: error: boost/program_options.hpp: No such file or directory

    This line seems to be the cause. Can you check if you have the boost lib install ?

    Vincent

    PS: configure should have failed with no boost installed

     
  • Logged In: YES
    user_id=404997
    Originator: YES

    yes, I have it installed, th configure script checks for some threads header and fails if it is not found.

    I tried to search the debian package database but I could not find such file at all.

     
  • Logged In: YES
    user_id=404997
    Originator: YES

    After more searching it turns out that program options and regex are in separate packages. I am not sure why they split off program options but regex is certainly not a header-only or even lightweight extension, it requires icu.

     
  • Yoda-JM
    Yoda-JM
    2007-10-06

    Logged In: YES
    user_id=1319653
    Originator: NO

    Boost is c++ only library. It is not quite simple to test it with the autoconf standard option. Boost library has in fact a lot of libs to link with. I suppose that if the headers are installed (-devel packages) the libs are too.
    I'm going to add the new boost headers required by USNG.
    Could you confirm that once the boost packages installed the compilation successed ?

    Vincent

     
  • Yoda-JM
    Yoda-JM
    2007-10-11

    Logged In: YES
    user_id=1319653
    Originator: NO

    Assume this bug is close (boost check should be ok in CVS)

    PS: please reopen if bug is recuring

     
  • Yoda-JM
    Yoda-JM
    2007-10-11

    • status: open --> closed
     
    • status: closed --> closed-fixed
     
  • Yoda-JM
    Yoda-JM
    2007-10-11

    Logged In: YES
    user_id=1319653
    Originator: NO

    Did you re-reun autogen.sh to regenerate configure script (from
    configure.in).
    If you do so, the configure script should have failed.

    Vincent

     
  • Yoda-JM
    Yoda-JM
    2007-10-11

    Logged In: YES
    user_id=1319653
    Originator: NO

    woups ..... should be tired .. sorry for the noise