Preview fails with certain RAW formats

2013-03-27
2013-04-11
  • Heikki Kantola
    Heikki Kantola
    2013-03-27

    I have noticed that with the latest UFRaw releases there appears to be problems in processing certain RAW formats. First I found that ARW files from my Sony A900 failed to show any preview images. Then I decided to check if there is anything wrong with the files from the other cameras I have used and ARWs from other Sony models (A700, A55, A77) work fine, but the MRWs from ye olde Konica Minolta Dynax 7D exhibit the same problem as A900 files.Otherwise UFRaw RAW processing appears to work ok, but without preview it isn't easy to make any sensible adjustments. And earlier versions (at least up to v0.18) didn't have this problem.

     
  • I get review images with the Konica Minolta 7D and Sony A900 samples from www.rawsamples.ch using UFRaw 0.19.2 on Windows. Make sure you use UFRaw 0.19.2 (not 0.19 or 0.19.1). What operation system are you using?

    Regards,
    Niels Kristian

     
  • Heikki Kantola
    Heikki Kantola
    2013-04-01

    I'm using Ubuntu 12.10. And I just built the 0.19.2 release and then tried that with my files: still the same problem. Then I decided to check those sample files and to my surprise these opened without problem. This is really puzzling! I don't think there can be anything wrong with the actual files, since I tend to shoot RAW+JPEG and JPEGs appear to be fine and likewise RAW files from my A55 and A77 cameras work ok. And with earlier UFRaw versions I did get previews also with KM 7D and A900 RAW files - albeit that might been on other computers (also running either Debian GNU/Linux and Ubuntu).

     
  • Strange. Can you make one of the problematic image files available for download?

    Regards,
    Niels Kristian

     
  • Thanks for the Pictures. I have no problem getting preview images with your files using UFRaw 0.19.2 on Windows or Ubuntu 12.04 or 13.04. I have attached a screenshot.

    Please remove the .ufrawrc file from your home directory and try again. If that does not help you can change -O3 to -O2, -O1 or -O0 i configure.ac, run autoreconf, ./configure and make. Let me know if that helps.

    Regards,
    Niels Kristian

     
  • Heikki Kantola
    Heikki Kantola
    2013-04-04

    Ok, I skipped testing with -O1, but at least with -O0 I managed to compile a working version.

    I am also starting to think that this might be related to the earlier report on Ubuntu 12.10/GCC 4.7.x problems: http://sourceforge.net/p/ufraw/discussion/434060/thread/f9f5e014/

     
  • Did you get any warnings like the ones shown below when you started the non-working UFRaw builds from a terminal Windows?

    (ufraw:2044): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

    (ufraw:2044): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion `GDK_IS_PIXBUF (pixbuf)' failed

    Regards,
    Niels Kristian

     
  • Heikki Kantola
    Heikki Kantola
    2013-04-08

    I cannot remember the exact error messages, but yes, I got at least some "GdkPixbuf-CRITICAL" messages when the program encountered problems previewing a RAW file.

     
  • It might be a compiler optimization bug, but I would like you to reproduce and post the full set of warnings.

    Regards,
    Niels Kristian