Installing on Windows Vista with GIMP 2.8.2

Ryto
2012-08-27
2013-02-27
  • Ryto
    Ryto
    2012-08-27

    OS:  Windows Vista Home Premium SP2 32-bit

    Following the instructions for Windows from the UFRaw download and install page.

    Installing UFRaw is a two-step process:

    1. Install Gimp-2.4.6 or later from the Gimp for Windows page.

    2. Install UFRaw from here.

    Both Gimp and UFRaw have a graphic installer. Just follow their instructions and make sure you are installing Gimp before installing UFRaw.

    However, the UFRaw installer automatically tries to install UFRaw to its own directory, and I subsequently get this error message:

    ufraw.exe - Unable To Locate Component

    This application has failed to start because libgdk-win32-2.0-0.dll was not found. Re-installing the application may fix this problem.

    After searching for a while, I found some threads about similar problems…

    Finally, I found the answer in this thread, but specifically this post (emphasis mine):

    udifuchs
    UFRaw has to be installed in the same directory as the Gimp. Maybe the option to choose a directory in the installer is misleading. This option can be used if you install the GTK library. It doesn\'t work if you only install Gimp.

    After poring over the installer steps again, it seems that the installer does have a note about this:

    Select Destination Location
    UFRaw should be installed in the GIMP directory. Hopefully, the wizard will guess your GIMP directory correctly.

    However, in my opinion, it is very easy to miss this note.  Could this step be addressed on the page about installing in Windows?  Perhaps in an FAQ?  Could it be made to stand out more in the Windows installer itself?

    Now, on to a possibly related, but somewhat separate problem:  using UFRaw 0.18 with GIMP 2.8.x.  According to this bug report, this is may not possible.

    Does the Windows installer fail to detect the GIMP directory because I\'m using GIMP 2.8.x and not GIMP 2.6.x, or does the detection fail in earlier versions of GIMP as well?  Also, could a note be added somewhere aside from that bug report (install page, FAQ, etc.) that UFRaw 0.18 was built using GIMP 2.6.x and therefore may not function correctly with GIMP 2.8.x.  This seems like it will become a common issue the longer that GIMP 2.8.x is the current stable release, so it might relieve headaches on both sides (users and devs) if this information is prominently displayed somewhere.

    Does the CVS version of UFRaw work with GIMP 2.8.x?  If, and that\'s a big if, I wanted to try to build the CVS version for Windows, is the current CVS considered stable, or is there a specific revision that would be recommended to try?

    My apologies for the wall of text and the loads of questions.

     
  • Ryto
    Ryto
    2012-10-02

    I hate to bump, but does anyone have any insight on this?

     
  • Drew Dunn
    Drew Dunn
    2012-11-25

    The solution to this issue is as follows, assuming that you have installed GIMP 2.8.2 to your C: drive:

    1. Install GIMP 2.8.2 as normal.
    2. Install UFRaw to the GIMP folder "C:\Program Files\Gimp 2\32"
       (Note: UFRaw will try to append "\UFRAW" to that folder.  Don't let it.)
    3. Copy the plugin program ufraw-gimp.exe from "C:\Program Files\GIMP 2\32\lib\gimp\2.0\plug-ins" to "C:\Program Files\GIMP 2\lib\gimp\2.0\plug-ins".
    4. Start UFRaw. Click on the "Options" button in the lower right hand corner and change the "Remote Gimp Command" to "C:\Program Files\GIMP 2\bin\gimp-2.8.exe" (do include the quotes).

    UFRaw should perform correctly after all of that.