#21 Thunderbird 3.0 release candidate 1 unpossible to use

closed-fixed
nobody
None
5
2009-12-18
2009-11-25
Anonymous
No

If you want install Thunderbird 3.0rc1 then give ubuntuzilla the following error : The version should contain only numbers and dots, and must begin and end with a number. Please try again. This comes because you dont allowed to type more then one letters: So if you want type "3.0rc1" then is it in this case not possible to use with ubuntuzilla or another thunderbird candidate releases in the furture

Discussion

  • nanotube
    nanotube
    2009-11-25

    Hi

    That is expected behavior - ubuntuzilla only tracks official releases, not betas or release candidates.

    If you want to install pre-release versions, either do that manually, or you can take out the version sanity check from ubuntuzilla code, and hope it works. :)

    it used to be that pre-release versions were stored in different directories, so it wasn't a simple matter of changing the version string... I just checked it out now, and it seems that everything is now consistent... so I think it /should/ work if you just take out the version sanity check and manually enter your 3.0rc1 version string.

    Give it a try... if it works, let me know, and maybe then instead of failing, I'll have ubuntuzilla just print out a big juicy warning instead, when someone enters a pre-release version.

     
  • nanotube
    nanotube
    2009-11-25

    • status: open --> pending-wont-fix
     

  • Anonymous
    2009-12-02

    Actually, it's not a matter of "pre-release" version or not.
    It is a real bug in the script coz the 3.0 "beta" versions can be installed, but not the "release candidates".

    In order to make ubuntuzilla work, you need to uncheck the manual input version by doing the following modification:
    Edit the file /usr/local/bin/ubuntuzilla.py (root)
    Go to line 405 and replace the expression by "if 1 == 1:"

    Note that it will disable the manual version input check, so you have to provide the right one.
    With this modification, Ubuntuzilla will accept to load the version 3.0rc2 (for example) of thunderbird.

    Enjoy.

     

  • Anonymous
    2009-12-02

    • status: pending-wont-fix --> open-wont-fix
     
  • nanotube
    nanotube
    2009-12-02

    Hi Thomas,

    Well, indeed it is a bug that the beta versions were allowed :) i forgot to escape the '.' in the regexp.

    That said, what you are proposing is exactly what i suggested (take out the version sanity check), though i shudder a little at the "if 1==1" idiom. :)

    anyway, i take it you have tested it with the rc and it worked? let me know, and if so, i'll make it warn rather than fail on the sanity check, so that someone who really does want to install the beta/rc can do so.

     
  • nanotube
    nanotube
    2009-12-03

    Hi,

    Well... the latest release of ubuntuzilla (4.8.0) now supports the manual entry of beta and rc versions. So give it a try. :)

     
  • nanotube
    nanotube
    2009-12-03

    • status: open-wont-fix --> pending-fixed
     
    • status: pending-fixed --> closed-fixed
     
  • This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).