Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo


INSERT Problems

  • Hi all!

    First of all, I would like to thank everyone which is working on these two excellent projects (UBCD and Insert)!

    While examining the INSERT integration in UBCD 3.0, I found that there is a problem with the documentation which is refereced through a s.link
    This link goes from (inside INSERT) /home/insert/file_x to /cdrom/docs/insert/file_x
    which is OK, but the dir. structure in UBCD is /docs/Insert/file_x ... :-)

    The next one is a little harder. I tried to integrate both "mods" (ff and nettools) into UBCD-full and found that something (KNOPPIX? INSERT?) won't "mount" it whith an error saying "no (more) cloop devices"...
    Anyone who knows were to increase this number?

    TIA. Salut, Jrg

    • Charles Appel
      Charles Appel

      Sorry for the delay: somehow my response didn't get posted back to this fourm.  Here is my original response:

      Hi Jorg:

      I'm the maintainer of UBCD Insert.

      We were just informed of the documentation path mixup
      the other day and will be releasing a fix by the end
      of the month.  It should only be the UBCD Documentation
      that's missing; all other should be there.  The UBCD
      Documentation is the file /docs/ubcd-index-table.html
      (outside of Insert, and /cdrom/docs/ in side).  It
      only really contains a list and links to documentation
      of stuff outside the Insert environment however.

      Regarding not enough cloops: this is strange and at
      the moment I'm stumped so I'm going to ask a few

      - Did you see the "Checking for modules on CDROM"
        message when starting (it comes right after DHCP
        broadcast message).  If it goes by to quick, type
        'insert 2' at the boot prompt to go in to console
        mode.  You should see the message.
      - From the shell, please type 'lsmod' and tell me the
        number in the 'used column'.
      - From the shell, type 'll /dev/cloop*' and tell me
        what you see.
      - Are the modules on CDROM or a USB device?
      - How much RAM do you have?

      You can't add more cloops since this is done when
      Insert is compiled (so to speak).  I'll add more
      for the next release, but I'm pretty sure that
      won't fix your problem.  Insert on CDROM is static,
      so there is no reason I can think of your system
      would require (or use) any more cloop devices than
      anyone else.


    • Hi Charles,

      thank you for your response!

      I think I have to apologize myself: <shame>
      After downloading I renamed the mod-tarfiles vom .tar to .mod because I thought, they were the real mod-files...
      After some investigation I found that the mods were inside the tar... </shame>

      So the problem was not with your mods but "betwen keyboard and monitor" :-)

      Now everything works fine (except for the displaced docs).

      Thank you again! Salut,

    • Marsha

      Great work getting Knoppix on the UBCD distribution!

      I'm also having startup problems and could use some help - I guess I'm more of a novice than I thought.

      1. I have the same error as the above poster, but I didn't make the same mistake - I extracted both nettools.mod and firefox.mod and put them into the INSERT folder and did a rebuild. I get the same error described above, and my answer to your questions are:
      did I see the "checking for CDROM.." yes
      lsmod listed in the used column for cloop = 2
      ll /dev/cloop gives
      brw-------  1  root  240,  0  May 28 2000  /dev/cloop

      the modules are on CDROM
      and I have 512MB ram.

      2. I'm trying to stay in Fluxbox, so how would I access firefox or the nettools from there?

      3. Readme at the top of the Fluxbox screen gives an error (probably same one described above caused by the misplaced doc files.)

      4. I then tried to use another browser as follows
      in Fluxbox right-click->network->Links browser

      and I immediately get an error box
      Error loading http://www.insert.cd/:
      Host not found

      So, I haven't got very far yet. BTW, I can see (via IP address) all other machines on my network. However I can't ping any outside host, it acts like DNS isn't getting into the network stack.

      Thanks for helping and sorry for the long post

      • Charles Appel
        Charles Appel

        1) Check the MD5 sum of your .mod files.  They should be:
        1fedd9b9de1a1ef79b35e8ea2dc0a7a6  firefox-0.8.mod
        eac23d039f6dfb14f84ff21648b8664a  nettools-1.0.mod

        Also, try the following: At the boot: type 'insert 2' without quotes. After your network device is detected, look for the line that says "Checking for INSERT modules on CDROM...".  See what it says.  Your module files should be in /INSERT.

        2) Fluxbox comes up automatically (unless you're in init mode 2, as described above).  If your modules loaded successfully the icons will appear on your desktop.

        3) The readme has not been a problem (only the UBCD Documentation was a problem in 3.0, which was fixed in 3.1), so I'm not sure why you would be getting an error.  Might want to send us the procedure you used to re-create the ISO (for example, the mkisofs line you used, what OS, what version of UBCD, etc).

        4) Yes, looks like there is a problem with DNS.  This has not been a reported problem with Insert/Knoppix related distros so it could be:
        1) A temporary problem with the DNS servers for insert.cd
        2) A problem with you're LANs DHCP server.

        I suggest you try the following:
        1) Within links, hit the 'g' key and enter in a different URL.  See if you get anywhere.

        2) Drop to the shell (Root X-Term) and type 'cat /etc/resolve.conf'.  Are there any 'nameserver' lines?  Can you type 'dig www.google.com' and get back a response?

        I assume you're getting an IP address since you said you can 'see' other machines.  But to be sure, type 'ifconfig' and see if there is anything interesting there.

    • Marsha

      Ok, thanks for the response.

      First some info on my build setup. I'm on a WinXP-SP2 machine, and am using the iso from Ultimate Boot CD v3.0 (the very latest). I've added a couple of my own DOS programs to that part of things, but everything else is as distributed. I did the file extraction directly from a CD I created from the ISO file (I use Nero 5). The mkisofs line I used is a build.bat file from the UBCD site containing the following:
      mkisofs -N -J -r -o \ubcd.iso -b boot/loader.bin -no-emul-boot -boot-load-size 4 .

      It looks like  I've got two separate problems:

      1) My md5 checksums for both firefox and nettools don't agree with the above. I've downloaded both tar files again (from different host sites) and get the same results - and my byte count for the tar files agree with that posted on the sourceforge site.

      # MD5 checksums generated by MD5summer (http://www.md5summer.org)
      # Generated 12/6/2004 2:56:36 PM

      55fd0eb6168b2fa6bccd15cfa070fc89 *nettools-1.0.mod

      # MD5 checksums generated by MD5summer (http://www.md5summer.org)
      # Generated 12/6/2004 2:55:28 PM

      3a166457fa19dacdceb8f55f8d13309c *firefox-0.8.mod

      and, yes I've used 'insert 2' to drop to the shell, and the relevent results are:

      Checking for INSERT modules on CDROM...
      Loading /cdrom/INSERT/firefox-0.8.mod...
      ***No free cloop devices! ***Regenerating ld.so.cache...
      and it continues with the ethernet setup which goes ok.

      Something very strange going on here!

      2) DNS service isn't working.
      I can get Links to work if I use (e.g.) the IP address for yahoo instead of the name www.yahoo.com. So the problem is DNS, not Links.

      cat /etc/resolv.conf (Note: NOT resolve.conf) provides 3 nameserver entries that are the proper IP addresses of my ISP's DNS servers. So that part is quite correct. Typing 'dig http://www.google.com' gives a full page response of all their registration data, so that appears to work. However, something as simple as a ping to www.yahoo.com does not work, but a ping to IP address works just fine.

      ifconfig results look just fine - my ethernet adapter and the loopback. And yes, DHCP must have worked just fine since I have a good IP address, resolv.conf has the proper DNS servers, and I can do pretty much everything at the command level with addresses, just not names.

      What do you suggest I try for 1) and 2) next?

      I do appreciate the effort and help.


      • Charles Appel
        Charles Appel

        FYI: Latested is UBCD 3.1, posted a few days ago.  The only fix is pointing to the correct UBCD Documentation, which is not too useful when in Insert, so in my opinion, not worth the download.

        I just downloaded firefox-0.8.tar, extracted and the MD5 came out to: 1fedd9b9de1a1ef79b35e8ea2dc0a7a6 the tar file is: a7432e47814fe33517f7879c4dde1b0d

        If your .tar file maches what I've posted, then it must be in the .tar extraction.  I don't have Winzip on any of my systems, but I seem to recall it has a "feature" of CRLF translations for .tar files.  You DO NOT want this enabled; it will corrupt the contents of the mod file.  Under windows, I use 7-zip for tar extraction. Cloop will give the message "no available cloop" if it can't understand the file, so in this case, it won't work unless your MD5 matches mine.  If your .tar does not match my MD5, hmmm; I'm using the NY mirror...

        2) I'm a little perplexed.  Maybe (unlikely), the corrupt .mod file is having a negitive impact on basic Linux operations.  If you don't get the .mod file stuff fixed, try 'insert nomods 2' at the boot prompt. (Note, once everything is fixed, you won't want to run in init mode 2 anymore).

        When you type 'ping www.yahoo.com' does it then respond with 'PING www.yahoo.akadns.net (x.x.x.x)' x = IP octet. Or does it say 'unknown host www.yahoo.com'?

        I've never run dig with a protocol prefixed, and I get different results if I prefix with http.  Try it without the http; e.g. 'dig www.google.com'. Our results may differ, but I get 11 NS and 11 A records when I do only the 'www.google.com'. If you are only getting 1 Authority response, name resolution is failing.  On second thought, try 'nslookup www.google.com'; dig's results can sometimes be hard to interpret.

        If you get multiple IP addresses, try typing 'wget www.google.com'; it should download an index.html file (useless, but a good test).

        Are you running in any sort of emulated environment (Virtual PC, VMWare, etc)?

    • Charles Appel
      Charles Appel

      Ahh, I just noticed Sourceforge is prefixing all my www's with http.  In the tests I've suggested above, do not prefix with http://.

    • Marsha

      Well, well, as you probably suspected, you nailed my problem with firefox and nettools - I had WinZip set with the CR/LF box checked - removed the check and all is wonderful - great help and insight.

      So, made a new CD and everything loads just fine. And I do not use any sort of emulated environment.

      The readme still gives the error
      Error loading file:///home/insert/docs/start.html:
      No such file or directory

      (and of course, there really is since I checked via the command line.)

      Still no joy with the DNS problem. Note this forum did the same to me as you with the www prefix stuff - so I'll use ! as a substitute to fake it out.

      ping www!google.com just gives u'unknown host.'

      nslookup www!google.com gives 'can't find www....'

      wget www!google.com gives 'resolving www!google.com.....failed: Host not found'

      Of course all these commands work just fine if I use the akadns address of instead of the name.

      gak, gak, gak.

      Any suggestions of something else to try?

      Thanks for your patience - and sorry about my novice goof with WinZip.


      • Charles Appel
        Charles Appel

        OK, making progress...

        As far as the readme is concerned, might want to drop to the shell and see if /home/insert/docs exists (and related files).  The are symbolic links to /cdrom/ so also make sure the files exist there too.  There was only one problem reported with documentation in UBCD 3.0 and what you're describing wasn't one of them; I'm suspicious of your file contents.

        At least we know names are not getting resolved; DNS is not working. This could be way off base, but aside from loopback and eth0 are there any additional network cards? If so, are they on the same subnet as your DNS servers?

        Try these tests:
        cat /etc/resolv.conf
        try to ping each nameserver by IP address (some ISPs won't allow you to ping thier servers).

        Then, try the following:
        'dig @nameserverip !www.google.com'
        (I'm using your ! convention)
        replace nameserverip on each test with your DNS server listings.

        If you see 11 or more NS and A records it worked, if not it failed.

        The dig @ convention bypasses normal nameserver resolution and is probably the most fundemental test you can run.  If that fails than I'm at a loss. Are you sure you're getting a valid, public (not private) IP address?  Who is assigning this, you or your ISP?  Are you behind a firewall? Does it NAT? Do other systems at your location use these same nameserver IP addresses?

        A few more random thoughts:
        Does your ISP require PPOE?  Some DSL providers are using this which requires authentication.  I don't know how to set this up under Knoppix related distros but I'm sure it can be done. I could see how they might deny access to thier nameservers without auth, but allow icmp.

        You might also want to try and download RIP (Recovery is Possible).  It's a nice, small distro that is not based on Knoppix; this might be good to see if it works under RIP.  I would not try another Knoppix distro since the code Insert uses is really the same as Knoppix.  RIP can be found: http://www.tux.org/pub/people/kent-robotti/looplinux/rip/

        Get the Bootable CD version.  If that does not work, it's either a PPOE issue, or some incompatibility with how your nameservers respond.  A user suggested some people may have to drop to the Windows shell and type 'ipconfig /release', then boot into Knoppix to get thier Internet working.

        Lastly, since Insert is based on Knoppix, you can search the fourms at www.knoppix.net.

        Please let us know how things are working out.
        -- Charles

    • Marsha

      And no, it was Sourceforge that put the http:// in the nslookup result -jeez

    • Marsha

      Hello Charles,

      You know I really appreciate your extensive help, but we aren't getting there. Here is my (hopefully not too rambling) status from trying things:

      All of the DNS tests you suggested work just fine.

      My network has 8 computers on it, fronted by a Netscreen router/gateway. Yes, the Netscreen does NAT and all computers run on an internal network with the Netscreen box also providing DHCP service. My public IP address is fixed, so no PPoE, and all external and internal IP addresses are just fine. I assure you I'm pretty good at this and both Windows and Lycoris Linux are running just fine on this network, and on the same machines (2) that I've been dealing with UBCD and INSERT on.

      The nameservers work just fine also. Your suggested test where I used 'dig @nameserver www!google.com'  gave good results with all three of PacBell's nameservers that I have listed in the Netscreen box.

      So, I tried the 'ipconfig/release' to clear the card and stack and then rebooted into INSERT - no joy.

      Since RIP is already on the UBCD, I presumed (?) that I should try it, instead of going through the process of retrieving it from the net again. It didn't help much since it doesn't appear to have any networking built-in. A couple of the other Linux distro's on UBCD do have networking built-in, but none would get an IP address, so I didn't get anywhere with them (I don't know how to manually configure IP, MASK, GW, and nameservers in these, sorry.)

      So, here's the big one. I already had a copy of Knoppix (v3.3) on a CD, so why not try it. Exact same problem!! Of course you aren't surprised - clearly my problem has nothing to do with UBCD or your INSERT efforts, but something to do with my use of Knoppix. I tried the Knoppix CD on a couple of other machines, but they are new ones with Intel GB ethernet chips and the network adapters just weren't recognized, so I'll have to get an older machine to try this further.

      Another experiment I tried: on the UBCD is a (DOS I guess) program called Arachne - it's a stand-alone browser and emailer, I think. I started it and it browses all sites just fine, i.e. it has no problems with name resolution at all.

      So, all I can conclude is that Knoppix doesn't like me, and you have been great to stick with this.  If I can find some time, I may scan the Knoppix site to see if this or something similar is discussed.

      I can't say thanks enough, and sorry that all your efforts didn't get better results for me. I did learn quite a bit.

      • Charles Appel
        Charles Appel

        Running out of ideas...
        It sounds like you know what you're doing so this is indeed a perplexing problem.  From here I think it's a matter of narrowing down the problem by running more tests.

        At this point, I would try the following:
        Edit /etc/resolv.conf to only contain 1 nameserver line with an IP address and remove anything else (such as "search" or whatever else might be there).  See if that works.

        From there I would run Ethereal, start capturing UDP 53 and see if I couldn't tell what was going on.  If, when you try to resolve (dig !www.google.com is a fine test) you don't see any UDP 53 traffic, then that might narrow it down to the resolver library.  If on the other had you do see traffic, I would look at the data payload to see if there are any unusual responses.  I don't know if the output will make sense to you, or if you will be able to save and post the output file, but if you can make it available I'd take a look at it.

        Yes, the RIP on UBCD is the floppy version, so to test a non-Knoppix it you'd have to download the RIP ISO.

        Insert runs on my Intel GB NICs, does it not recognize the card on your newer systems?