#46 configure fails

closed-invalid
nobody
None
5
2009-06-13
2009-06-06
No

Hi,
I am trying to compile Twitux and got this !!

Regards,
DALI

PS. I am not familiar with linux compiling

configure: error: Package requirements (
libsexy
gtk+-2.0 >= 2.14.0
glib-2.0 >= 2.15.0
gio-2.0 >= 2.15.5
libcanberra-gtk >= 0.4
libsoup-2.4
libnotify

dbus-1 >= 0.61 dbus-glib-1
) were not met:

No package 'libsexy' found
No package 'libcanberra-gtk' found
No package 'libnotify' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables TWITUX_CFLAGS
and TWITUX_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

checking for TWITUX...
*** Exited with status: 1 ***

Discussion

  • Brian Pepple
    Brian Pepple
    2009-06-13

    • status: open --> closed-invalid
     
  • Brian Pepple
    Brian Pepple
    2009-06-13

    Your getting this compilation failure because you don't have the necessary devel files (in this case libsexy, libcanberra-gtk, and libnotify) installed.