Thank you for the quick help. I packaged it for Arch Linux.

On 7/23/07, Bill Kendrick <> wrote:
On Mon, Jul 23, 2007 at 04:26:19PM +0200, Ben Egger wrote:
> hi,
> i get a compiling error with version 0.9.17:

Hi Ben - as of v.0.9.17, Tux Paint now depends on 'libpaper'.  If you already
have that package installed, as the error message said, you _also_ need the
'devel' version of the package (which contains the C header file) to be able
to build Tux Paint from source.

What platform are you trying to build TUx Paint on?  Presumably Linux or
some other Unix.  If Linux, what distro?  Is libpaper available?  If not,
perhaps we have it for you (Shin-Ichi packaged it for some Red Hat and
Fedora versions, for example: )

Good luck!

> ...Compiling PostScript print support...
> src/postscript_print.c:51:19: error: paper.h: No such file or directory
> src/postscript_print.c:55:2: error: #error
> "---------------------------------------------------"
> src/postscript_print.c:56:2: error: #error "If you installed libpaper from a
> package, be sure"
> src/postscript_print.c:57:2: error: #error "to get the development package,
> as well!"
> src/postscript_print.c:58:2: error: #error "(e.g., 'libpaper-dev.rpm ')"
> src/postscript_print.c:59:2: error: #error


This email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>
Tuxpaint-devel mailing list