#19 UnsupportedClassVersionError on Startup

open
nobody
None
5
2013-08-26
2012-09-06
BitSchupser
No

I cannot start Tuxguitar on Arch Linux 3.5.3-1 64 Bit.

If I run the command "tuxguitar" on the Shell, I got the following Stack Trace:
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/eclipse/swt/widgets/Control : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)

My Java Version:
$ java -version
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.4) (ArchLinux-6.b24_1.11.4-1-x86_64)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

My Tuxguitar Version: 1.2-5 (form Arch community repository)

If you need additional information about my system, please write a comment.

Discussion

  • Blaine Simpson
    Blaine Simpson
    2013-08-21

    Unless you're modifying source code, you will probably be much happier using the modern product by checking out just svn://svn.code.sf.net/p/tuxguitar/code/trunkTuxGuitar-testing and using the relevant *.sh script from there.

    If you had the problem when using that script, I'd be happy to help you.

     
  • It seems that the SWT version you are running was compiled with a higher java version than yours