configure.in:9: warning: underquoted definiti

Help
2004-12-06
2013-06-04
  • [root@dynamic src]# cd /usr/local/src/turck-mmcache-2.4.6
    [root@dynamic turck-mmcache-2.4.6]# export PHP_PREFIX="/usr"
    [root@dynamic turck-mmcache-2.4.6]# $PHP_PREFIX/bin/phpize
    configure.in:9: warning: underquoted definition of PHP_WITH_PHP_CONFIG
      run info '(automake)Extending aclocal'
      or see http://sources.redhat.com/automake/automake.html#Extending%20aclocal
    configure.in:32: warning: underquoted definition of PHP_EXT_BUILDDIR
    configure.in:33: warning: underquoted definition of PHP_EXT_DIR
    configure.in:34: warning: underquoted definition of PHP_EXT_SRCDIR
    configure.in:35: warning: underquoted definition of PHP_ALWAYS_SHARED
    acinclude.m4:19: warning: underquoted definition of PHP_PROG_RE2C
    /usr/share/aclocal/vorbis.m4:9: warning: underquoted definition of XIPH_PATH_VORBIS
    /usr/share/aclocal/pkg.m4:5: warning: underquoted definition of PKG_CHECK_MODULES
    /usr/share/aclocal/ogg.m4:8: warning: underquoted definition of XIPH_PATH_OGG
    /usr/share/aclocal/libmikmod.m4:11: warning: underquoted definition of AM_PATH_LIBMIKMOD
    Configuring for:
      PHP Api Version:   20020918
      Zend Module Api No:   20020429
      Zend Extension Api No:   20021010

    - Anyone know what I can do to not get this error?

    My PC:

    Intel PIII - Fedora Core 2
    - Apache 2.0.51 (Fedora)
    - PHP Version 4.3.8
    - Zend Engine v1.3.0

     
    • shin seung woo
      shin seung woo
      2004-12-06

      yes. I have same problem with phpize.

      but, It's just a warning.
      no problem I think,

      just keep continuing, ./configure; make;

       
    • [root@dynamic turck-mmcache-2.4.6]# ./configure --enable-mmcache=shared --with-php-config=$PHP_PREFIX/bin/php-config
      checking build system type... i686-redhat-linux-gnulibc1
      checking host system type... i686-redhat-linux-gnulibc1
      checking for gcc... gcc
      checking for C compiler default output file name... configure: error: C compiler cannot create executables
      See `config.log' for more details.
      [root@dynamic turck-mmcache-2.4.6]# make
      make: *** No targets specified and no makefile found.  Stop.
      [root@dynamic turck-mmcache-2.4.6]#

       
    • shin seung woo
      shin seung woo
      2004-12-06

      checking for gcc... gcc
      checking for C compiler default output file name... configure: error: C compiler cannot create executables
      See `config.log' for more details.

      you don't have gcc or problem with gcc.

      check configure script in around 1960...
      this test is testing compiler is exist, configure trying to do compile follow C file, and check they  produce a.out or a.exe, ...

      int
      main ()
      {

        ;
        return 0;
      }

      suggestion is,
      1) type gcc and check if it is in path.
      2) check config.log
      3) make a.c file above, and compile with comand 'gcc a.c'

       
    • [root@dynamic html]# gcc a.c
      a.c:7:2: warning: no newline at end of file
      /usr/bin/ld: crt1.o: No such file: No such file or directory
      collect2: ld returned 1 exit status
      [root@dynamic html]#

      Is that good?

      P.S This is the first file I ever compiled.

       
      • shin seung woo
        shin seung woo
        2004-12-07

        I think this is good.

        % gcc a.c
        %

        /usr/bin/ld: crt1.o: No such file: No such file or directory
        collect2: ld returned 1 exit status

        ld says 'crt1.o' is missing. in my system, crt1.o is in glibc-devel package rpm.

        % rpm -qf /usr/lib/crt1.o
        glibc-devel-2.3.2-11.9

        I don't know about debian in case of debian.