Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

[r7423]: tags / 2.0rc1 / setup.py Maximize Restore History

Download this file

setup.py    63 lines (59 with data), 1.9 kB

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
import os
here = os.path.abspath(os.path.dirname(__file__))
execfile(os.path.join(here, 'tg', 'release.py'))
try:
from setuptools import find_packages, setup
except ImportError:
from ez_setup import use_setuptools
use_setuptools()
from setuptools import find_packages, setup
test_requirements = ['coverage',
'nose',
'TurboKid >= 1.0.4',
'zope.sqlalchemy >= 0.4',
'jinja',
'chameleon.genshi',
'repoze.what >= 1.0.5',
'repoze.who-testutil >= 1.0rc1',
]
setup(
name='TurboGears2',
version=version,
description=description,
long_description=long_description,
classifiers=[],
keywords='turbogears pylons',
author=author,
author_email=email,
url=url,
license=license,
packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
include_package_data=True,
zip_safe=False,
install_requires=[
'Pylons >= 0.9.7',
'Genshi >= 0.5.1',
'WebFlash >= 0.1a8',
'ToscaWidgets >= 0.9.4',
'WebError >= 0.10.1',
'repoze.what-pylons >= 1.0rc3',
'repoze.tm2 >= 1.0a4',
'TurboJson >= 1.2.1',
],
extras_require={
#XXX: Perhaps this 'core-testing' extras_require can be removed
# since tests_require takes care of that as long as TG is tested
# with 'python setup.py test' (which we should IMHO so setuptools
# can take care of these details for us)
'core-testing':test_requirements,
},
test_suite='nose.collector',
tests_require = test_requirements,
entry_points='''
[paste.global_paster_command]
tginfo = tg.commands.info:InfoCommand
[turbogears2.command]
serve = paste.script.serve:ServeCommand [Config]
shell = pylons.commands:ShellCommand
'''
)