#75 de2104x irq problem

open
Jeff Garzik
None
5
2005-01-23
2005-01-15
Anonymous
No

When booting 2.6.10 (vanilla) I get this error:

Dec 27 17:36:25 shelob kernel: de2104x PCI Ethernet
driver v0.7 (Mar 17, 2004)
Dec 27 17:36:25 shelob kernel: ACPI: PCI interrupt
0000:00:07.0[A] -> GSI 18 (level, low) -> IRQ 18
Dec 27 17:36:25 shelob kernel: eth1: 21040 at
0xd0efef00, 00:c0:95:ee:ff:67, IRQ 12
Dec 27 17:36:25 shelob kernel: eth1: enabling interface
Dec 27 17:36:25 shelob kernel: eth1: set link 10baseT-HD
Dec 27 17:36:25 shelob kernel: eth1: mode
0xfffc0040, sia 0xffffffcc,0xffff8f01,0xffffffff,0xffff0000
Dec 27 17:36:25 shelob kernel: eth1: set mode
0xfffc0040, set sia 0x8f01,0xffff,0x0
Dec 27 17:36:25 shelob kernel: irq 18: nobody cared!
Dec 27 17:36:25 shelob kernel: [<c013216a>]
__report_bad_irq+0x2a/0x90
Dec 27 17:36:25 shelob kernel: [<c0131c10>]
handle_IRQ_event+0x30/0x70
Dec 27 17:36:25 shelob kernel: [<c013225c>]
note_interrupt+0x6c/0xd0
Dec 27 17:36:25 shelob kernel: [<c0131d2a>]
__do_IRQ+0xda/0xf0
Dec 27 17:36:25 shelob kernel: [<c0105299>]
do_IRQ+0x19/0x30
Dec 27 17:36:25 shelob kernel: [<c01038fe>]
common_interrupt+0x1a/0x20
Dec 27 17:36:25 shelob kernel: handlers:
Dec 27 17:36:25 shelob kernel: [<c0255650>]
(usb_hcd_irq+0x0/0x70)
Dec 27 17:36:25 shelob kernel: Disabling IRQ #18

Afterwards the card doesn't work.
It worked last in 2.6.9 I think.

lspci output:
0000:00:00.0 Host bridge: VIA Technologies, Inc.
VT8366/A/7 [Apollo KT266/A/333]
0000:00:01.0 PCI bridge: VIA Technologies, Inc.
VT8366/A/7 [Apollo KT266/A/333 AGP]
0000:00:06.0 Ethernet controller: 3Com Corporation
3c905B 100BaseTX [Cyclone] (rev 30)
0000:00:07.0 Ethernet controller: Digital Equipment
Corporation DECchip 21040 [Tulip] (rev 24)
0000:00:08.0 Multimedia audio controller: Yamaha
Corporation YMF-724F [DS-1 Audio Controller] (rev 03)
0000:00:09.0 SCSI storage controller: Adaptec
AHA-2940U/UW / AHA-39xx / AIC-7895 (rev 03)
0000:00:09.1 SCSI storage controller: Adaptec
AHA-2940U/UW / AHA-39xx / AIC-7895 (rev 03)
0000:00:0b.0 USB Controller: NEC Corporation USB (rev 41)
0000:00:0b.1 USB Controller: NEC Corporation USB (rev 41)
0000:00:0b.2 USB Controller: NEC Corporation USB 2.0
(rev 02)
0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8233
PCI to ISA Bridge
0000:00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE
(rev 06)
0000:00:11.2 USB Controller: VIA Technologies, Inc.
VT82xxxxx UHCI USB 1.1 Controller (rev 1b)
0000:00:11.3 USB Controller: VIA Technologies, Inc.
VT82xxxxx UHCI USB 1.1 Controller (rev 1b)
0000:00:11.4 USB Controller: VIA Technologies, Inc.
VT82xxxxx UHCI USB 1.1 Controller (rev 1b)
0000:01:00.0 VGA compatible controller: ATI
Technologies Inc Radeon R200 QL [Radeon 8500 LE]

I tried disabling ACPI, APIC support to no avail.
I also tried to move the card around in the PCI slots.
I got the same error anyway (with a different IRQ)
I am not even sure it's a bug in this driver...

The motheboard is an MSI KT266 Pro2A-RU
if you need more info please notify me
(oscar\at/axelero.hu)

Discussion

  • Jeff Garzik
    Jeff Garzik
    2005-01-23

    • assigned_to: nobody --> jgarzik