Package updates (2009/03/02)

=== jTSS 0.4a ===

This is a bugfix release which fixes an unfortunate bits vs.
bytes issue in TPM keyblob creation from Java keys. This error
affects all applications doing an AIK cycle with a PrivacyCA.

Consequently, all older releases are incompatible with other TSS
implementations (e.g. TrouSers) when doing an AIK cycle. Please
upgrade all your applications to jTSS 0.4a.

=== jTss Wrapper 0.4beta ===

Due to popular demand, this is an update to allow jTss Wrapper
to be build with current TrouSerS 0.3.1cvs. Note that this is
a BETA release which has not received much testing. Be careful.

=== PrivacyCA 0.2 ===

Another Trusted Computing PKI (APKI) package to run a PrivacyCA.
This is a redesigned version of the functionality provided in the
0.1 release. It was optimised to be as small as possible, thus doing
away with the XKMS and XML overheard and using a much simpler
protocol.

This release allows to run the PrivacyCA Java server in a 17Mb
Xen compartment (build instructions included). Further, commandline
demonstration clients for jTSS (Java) and TrouSerS (C) are provided.

Posted by mpirker_iaik 2009-03-02