Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

trying to use T-Plan with Mvnc server

Help
Anonymous
2010-05-11
2013-02-18

  • Anonymous
    2010-05-11

    Hi All,

    I am trying to use T-Plan to test symbian application.i have installed Mvnc server (http://www.m-shell.net/products/mvnc.aspx),but i am not able to connect t-plan with mvnc server.Should i have to enter phone;s ip address?
    The Mvnc server works when i try to connect to my pc which had vnc listner ie;phone is displayed on the monitor.how do i make T-Plan "listen" to the connection i make from the MVnc server on the phone

     
  • Robert Pes
    Robert Pes
    2010-05-11

    Use the -l/-listen CLI option. More details in the CLI specification.

     

  • Anonymous
    2010-05-11

    thank u so much ..but what is 'display' in -l, -listen

     
  • Robert Pes
    Robert Pes
    2010-05-11

    The display is just another way of specifying the port number. Use direct port instead (::port) if you don't understand the display concept from the spec.

     

  • Anonymous
    2010-05-11

    well i tried using 'robot -l ::5500' cli option.The gui of the t-plan is displayed and i tried connecting from the mVNC server from the symbian phone:But i am getting system error .The t-plan here is not able to 'listen' to the connection i guess.Please let me know if i have configured any thing wrong..Is there anything i have to configure/install in the T-PLAN

    The mVNC server is configured with following  details:
    1.host:the ip address of the windows system where the t-plan is running with RFB listned mode.
    tHANK U SO MUCH IN ADVANCE
    2.port:5500

    3.access point:wlan

    4.password:no password set

     
  • Robert Pes
    Robert Pes
    2010-05-11

    I retested the current code and indeed I found two bugs. One of them was introduced by another memory leak fix last week or so. Another one seems to have been there for a while.

    I fixed the code and submitted it to CVS. Help yourself if you build Robot from the code.

     
  • Robert Pes
    Robert Pes
    2010-07-12

    The bug fix was released today in 2.0.5.