Help: it doesn't work!

TG Site
1 2 > >> (Page 1 of 2)
  • Hi,

    I have tried with the Java run time provided by default (1.3...): it didn't work. Then I followed the instructions to de-install the Java runtime so I could install the new one (1.4.0), and it still doesn't work.
    I am running Windows 98 with IExplorer 6.

    The window does open up and it loads an applet, but the window remains blank.

    Thank you

    • Same problem here, except Windows XP.  Please e-mail me directly at  Thanks!

    • Yes, this was a temporary problem from July 13th-14th, where the traffic got so high that the sevice had to be shut down.

      This should be fixed now :-)


    • I have the same problem...Win98,IE6,Java1.3... This on 1Aug'02. Any ideas?
      Thanks, Ed

    • It works with links that you have on the site, but not on ones I specify.

    • same thing for me, W2k, JRE 1.3 or 1.4. I get just blank window.


    • Same W2k, JRE 1.3.1_04 (Default).  Blank Window

    • Hi Guys,

      For the people that get blank windows,

      Do you have java enabled? 
      Tools->Internet Options->Advanced->Java

      Does the page contain a broken picture or is it completely empty.  If it's completely empty then it could be that you need to enable java for your browser.



    • Hi Alex
        Saw you on SS.  Nice Kilt.
        I have Java Enabled but am now getting this error.

      Exception: java.lang.ClassNotFoundException: com.touchgraph.googlebrowser.GoogleBrowserApplet

      Any Ideas why I would get this error?  A setting in my browser?  IE 6, W2k, Sun Java 2 v1.4.

      Thanks Alex


    • I got rid of the Exception error by removing java 2 1.4 and installing 1.3 but am now back at the blank screen.  Low security on Java, All Java enabled.


      • Back to a blank screen!  I think that you were better off with Java 1.4.

        Unfortunately it seems that java applets are very platform sencitive, there are a number of other platform related bugs.  I'll try to debug it when I have time.  It would be helpful if you sent the full error from your java console.

        Also, if you could try the other applets of the main page, as well as the google-set-browser from Langreiters site, and see if any of those work, that could also narrow down the problem.

        Finally, try Netscape.  It's a roundabout way to go, but it works on some systems.

        Sorry, thanks, and I'm glad that you can appreciate a good kilt when you see one ;)


    • Here's what I gleamed after initially using GoogleBrowser and getting the same effect;

      1. The URL has to be Google related, check and see, if not then blank screen.

      2. If the URL is malformed, the same effect happens w/ this from the JavaConsole...

      Opening is bogus&maxDepth=2

      Connecting is bogus&maxDepth=2 with no proxy Connection failure with 400

          at sun.plugin.protocol.jdk12.http.HttpURLConnection.getInputStream(Unknown Source)


          at com.touchgraph.googlebrowser.TGGoogleBrowser.getRelatedNodes(

          at com.touchgraph.googlebrowser.TGGoogleBrowser.<init>(

          at com.touchgraph.googlebrowser.GoogleBrowserApplet.init(

          at Source)

          at Source)

    • Dennis Daniels
      Dennis Daniels

      Hello Alex!
      Unfortunately I"m having a similar problem though more troubling...TG works sometimes and not others!

      for example doesn't work but does doesn't work but does

      I'm a bit confused. I've checked the java console and it shows no error so it appears to something in the way the http request is made??

      thanks for a great app! and for any help you might have to offer in resolving this curious problem!

      • Hi Dennis,

        Glad to see that your interest in TouchGraph has kept up.

        The inconsistent behavior of the TGGoogleBrowser that you mentoin is a minor bug.

        Basically, a graph will only be generated if "" returns results AND if is one of the results returned.  In other words, the search string itself has to be one of the returned results.  It just so happends that for 99% of initial url's, the initial site is returned as being similar to itself.  But ocasianally, the site is not returned, or it's returned with a different prefix, say "www." if you entered the site without the "www".

        So, in order to check what's up with the graph not being generated, just do a "related:" search on google and make sure that the site is one of the resutls.

        Hope this clears up the mistery, let me know if there are some new bugs that don't fall under this explanation.



        • Anonymous

          Hi Alex,

          I tried to follow what you said regarding related links and all, and as far as I can tell the site I checked IS returned on the Google related links, but I still end up with a blank screen.  In fact, I've gotten a blank screen for most of the sites I've entered.  Note that I have had some successes, for example with the sites you've listed, and also,, and a few others.  However,, a very well known site, does NOT work.

          This is a really nice tool and I'd like to share it with friends and coworkers, but I need to see a more consistent, working result.  Any other ideas?

          FYI:  I'm using Windows 2000 and IE 6 with Java 2 version 1.4.0_03.

          Thanks, Leah

    • Hi,

      it doesn't work for me. I am using Mac OS 9.0, IE5 and Netscape 7. Both browsers were Java enabled and couldn't download the "URL from the browser". Any idea how I will be able to fix this?

      Thanks, Jens

    • Hi,

      it doesn't work for me. I am using Mac OS 9.0, IE5 and Netscape 7. Both browsers were Java enabled and couldn't download the "URL from the browser". Any idea how I will be able to fix this?

      Thanks, Jens

    • The Java version in Mac OS 9 is not high enough to be able to run the GoogleBrowser applet, unfortunately, and is unlikely to be updated.

    • Gene

      Picked up touchgraph from LangaList this morning. Did a search.  In Opera 7 (Java 1.4.1) the screen is blank. With NS 4.8, there is no URL entry slot. With IE6 it seems to work fine.  Normally, I use Opera.  I have NIS 2003 ad-blocking off. Anything else that this site is sensitive to?  I'm running XP.  Thanks,

    • Just found the answer in Opera.  Quick preferences has to be set to "Identify as Opera."  I had it on id as IE.

    • susan wang
      susan wang

      when i click on the thumbnails to enlarge screen shots, i'm getting the maps in a separate window, but no interactivity, none of the links to the sites when i click on them. the red tags, green circles and info buttons aren't available.
      seems the map is just a blowup image of thumbnail.
      i'm running windows 2000, ie 6, and mozilla firebird, with java 2 v1.4.2_01
      any ideas?

    • susan wang
      susan wang

      i should mention that java is activated in my security options in IE. not sure if mozilla has a similar option that needs checking.
      also i'm using earthlink's popup blocker (which i'm marginal on) in IE.

    • susan wang
      susan wang

      one more comment.
      when i hit "graph it" for entering a starting url, the browser just closes (no error message) and closes all other browsers of that type (mozilla or ie) that i have open.

    • I'm on a Windows 2000 Professional machine, using Firefox 1.0 browser and I've installed jre (windows offline install).  Touchgraph still doesn't work no matter what URL I try (even those pre-initialized on the page).

      load: class com.touchgraph.googlebrowser.GoogleBrowserApplet not found.

      java.lang.ClassNotFoundException: open HTTP connection failed.

          at sun.applet.AppletClassLoader.getBytes(Unknown Source)

          at sun.applet.AppletClassLoader.access$100(Unknown Source)

          at sun.applet.AppletClassLoader$ Source)

          at Method)

          at sun.applet.AppletClassLoader.findClass(Unknown Source)

          at Source)

          at java.lang.ClassLoader.loadClass(Unknown Source)

          at sun.applet.AppletClassLoader.loadClass(Unknown Source)

          at java.lang.ClassLoader.loadClass(Unknown Source)

          at sun.applet.AppletClassLoader.loadCode(Unknown Source)

          at sun.applet.AppletPanel.createApplet(Unknown Source)

          at sun.plugin.AppletViewer.createApplet(Unknown Source)

          at sun.applet.AppletPanel.runLoader(Unknown Source)

          at Source)

          at Source)

    • Is there a resolution to the Java applet problem and unstable operation?  This thread stops about 18 months ago.  A cool tool, I need to find a stable version or list of settings?  Anybody have the procedure worked out?

1 2 > >> (Page 1 of 2)