On 11/26/2013 12:19 PM, ivan@cvut.cz wrote:
Moreover - for example Fedora insist on packaging without Oracle  
support.

that's always the pain in the ass. I use "Packman" for suse. It's widely used service for software which cannot go to official distribution due licensing glitches. Oracle stuff is built agains 11.2 instantclient on the Packman's build service but instantclient packages are unable to download from there.

So suse users have to:
 - add new repository to packaging system
 - to install oracle (instant) client on their own
 - confirm (misleading) warning every time the oracle-related package is requested to install:

Problem: nothing provides libclntsh.so.11.1()(64bit) needed by tora-2.99.4905-2.1.x86_64
 Solution 1: do not install tora-2.99.4905-2.1.x86_64
 Solution 2: break tora-2.99.4905-2.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c): 2

I know it's far from perfection but I haven't discovered any better solution yet.

p.