I believe this tab is bugged for Oracle Applications (ERP), i.e. BIG databases.
 
Further testing - I thought for a while it was related to the server tuning tab SQL refreshes getting 'behind' in updating the screen, i.e. if it takes 20 seconds to refresh the screen and I'm refreshing every 2 seconds, the updates would back up.
 
So I was pretty careful to go straight to the server tuning tab and NOT doing any refreshes.  I'm getting mixed results, sometimes that works and sometimes it doesn't.  I hit 'refresh' once and it all seemed stable, however once I clicked from tab to tab it eventually blew up.  (this was with one refresh).
 
In watching the background SQL wheel, some tabs refresh once you click on them.  If I'm careful to only click on a new tab after the wheel quits spinning, it seems to work.  However, sometimes even doing that it blows up.  Crash in the same location as always.
 
I've tried this on a completely clean workstation with no 'gdi objects' being displayed on the task manager. I ran TOra, then went straight to the server tuning tab, and left the screen up, with no refreshes, and no clicking on other server tuning tabs.  I then set it for 5 minute refresh.  After some time (say half an hour) it blows up.
 
I have never been able to get the server tuning tab up for longer than 1-2 refreshes.
 
So - I have never been able to get this to work on any workstation.  HOWEVER I have always used this on an Oracle Apps version 11.5.5 - 11.5.8 (11i) ERP.
 
               == John ==
-----Original Message-----
From: John D. Gwinner
Sent: Tuesday, June 10, 2003 03:46 PM
To: Jeff Price; Henrik Johnson; tora-develop@lists.sourceforge.net
Subject: RE: [Tora-develop] TOra fell down and can't get up (memory/GDI le ak on Server Tuning tab)

I just noticed that I was emailing Jeff and Henrik directly, not the mailing list.
 
This is related to getting the 'server tuning tool' working.  It crashes within 2-3 minutes or right away for me.  It will not stay up if 'refresh' is turned to any value.  It sometimes crashes on the first manual refresh.
 
I tried it on a client workstation, and the same thing happened.  As a matter of fact, it worked for a while, but after about 5 minutes the entire desktop went 'gray' and it started drawing all over the desktop.  I couldn't get any tab on the server performance tab to stay up for longer than a minute or two.
 
Win2K, SP3, very clean machine (no development environment, etc).
 
I'm not displaying any GDI objects on the task manager when it crashes (per previous email).
 
I wonder if it's related to the data that the server tab is gathering - we are dealing exclusivly with Oracle Applications, in this case 11.5.8.  It's a quite large database (many schema's, 10k tables, etc).
 
I would really like to use the server tuning tab but it doesn't work at all for me.
 
This is version 1.3.9.2 (latest version WITH the server tuning tab).
 
All other tools seem to work ok.
 
               == John ==