TOra 2.1.3 - Wind7 - Oracle - Connection not open / TNS:could not resolve the connect identifier specified

Help
Yaerox
2014-01-10
2014-01-10
  • Yaerox
    Yaerox
    2014-01-10

    Hey guys,

    I wanna use TOra but didn't got any connection provider running on TOra 3 so I went back to 2.1.3 where I got connection providers but I still can't connect.

    I got TOra on a Windows 7 maschine, and I wanna use it to connect to multiple Oracle databases e.g. on my local Win7 (Oracle 10g) or on a VM (Ubuntu - Oracle 11g). I'm already using SQLDeveloper where all connections are working fine.

    When I'm using Oracle (TNS) as connection provider I'm getting ORA-12154 TNS:could not resolve the connect identifier specified on every try. SQL*Net is checked and no changes if I change the Database. Same error at all databases.

    When I'm using Oralce (Instant Client) I'm getting the following possible hosts: (3x localhost, 8x SQL*Net).

    localhost --> doesn't matter which database --> ORA-06413: Connection not open.
    SQL*Net--> doesn't matter which database --> ORA-12154 TNS:could not resolve the connect identifier specified.

    Can someone please help me out? :/

    Edit: I did an export from SQLDeveloper into a .XML and imported the file in TORA. Now I got the connections shown but still ORA-06413: Connection not open.

     
    Last edit: Yaerox 2014-01-10
  • Yaerox
    Yaerox
    2014-01-10

    Got this running. Installed Tora on C:\Program Files\ instead of (x86), and I installed the oci.dll too but I renamed after inatalling to _oci.dll.

    Now its working fine.