Compile TOra 2.0 with Oracle on Kubuntu 8.10

  • alchemist141

    I'm sooooo confused!

    I downloaded the TOra 2.0 source code, and expanded it to a local folder.  I have Oracle XE running locally and can connect via sqlplus.  I run the following command from the base source folder:

    ./configure --prefix=/usr --with-oracle=usr/lib/oracle/xe/app/oracle/product/10.2.0/server --with-oci-version=11G --with-instant-client=/home/jason/Documents/Downloads/oic/instantclient_11_1/ --with-oracle-includes=/home/jason/Documents/Downloads/oic/instantclient_11_1/sdk/include --with-oracle-libraries=/home/jason/Documents/Downloads/oic/instantclient_11_1

    It gives me the infamous "Couldn't compile and run a simpile OCI app" error. 

    What environment variables need to be set?  And to what paths?  For example, my ORACLE_HOME is set to /usr/lib/oracle/xe/app/oracle/product/10.2.0/client.  LD_LIBRARY_PATH??? Where should that point to?

    I thought if you simply extracted Oracle's Instant Client to a directory and used the --with-instant-client option, it would compile okay.  It's not!

    Anyone have hints or suggestions?  I'm soo lost!

    Thanks in advance,

    • didier asnar
      didier asnar


      you need to set LD_LIBRARY_PATH on the folder of the instant client ..

      you also need to download and install instant client dev kit (or a thing like that, needed for compilation)


    • Mike Johnson
      Mike Johnson

      You have a choice of Oracle (full) client or instant client, you don't want to mix them. (Ie, remove the --with-oracle).

      Please send the config.log if it still fails. Just open it up, go to the bottom of the file and search backwards for "fail". That should show you the last test that error'd out.

    • Mike Johnson
      Mike Johnson

      Actually, from the looks of it, you shouldn't need these:


      Those are for overriding defaults if configure finds or can't find the right folders. --with-instant-client should be enough. With 11g, it'll actually discover the OCI version, too.