Install issue with TOra 1.3.18 on CentOS 4.1

dbaxps
2005-11-13
2012-12-13
  • dbaxps
    dbaxps
    2005-11-13

    Perform free download from available mirrors
    1.qt-x11-free-3.3.5.tar.gz
    2.tora-1.3.18.tar.gz

    Configuring tora-1.3.18 with original version of Qt crashes due to absence
    of qt-mt library

    1. Unpack the Qt archive :

    # cd /usr/local
    # gunzip qt-x11-free-3.3.5.tar.gz
    # tar xvf qt-x11-free-3.3.5.tar

    This creates the directory /usr/local/qt-x11-free-3.3.5 containing the
    files from the main archive.
    Rename qt-x11-free-3.3.5 to qt (or make a symlink):

    # mv qt-x11-free-3.3.5 qt

    The rest of this file assumes that Qt is installed in /usr/local/qt.

    Source in root's bash environment:
    QTDIR=/usr/local/qt
    PATH=$QTDIR/bin:$PATH
    MANPATH=$QTDIR/doc/man:$MANPATH
    LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
    export QTDIR PATH MANPATH LD_LIBRARY_PATH

    # cd /usr/local/qt
    # ./configure -thread
    # make

    At this point Qt Library has been built

    Perform Instant Client Install:-

    # rpm -Uvh oracle-instantclient-basic-10.2.0.1-1.i386.rpm
    # rpm -Uvh oracle-instantclient-devel-10.2.0.1-1.i386.rpm
    # rpm -Uvh oracle-instantclient-sqlplus-10.2.0.1-1.i386.rpm

    Create orauser:-

    # useradd -g oinstall -G dba orauser
    # passwd orauser

    Login as orauser:-

    Orauser's profile

    PATH=$PATH:$HOME/bin
    export ORACLE_HOME=/u01/app/oracle/product/10.2.0/db_1
    LD_LIBRARY_PATH=/usr/lib/oracle/10.2.0.1/client/lib
    export TNS_ADMIN=/u01/app/oracle/product/10.2.0/db_1/network/admin
    LD_LIBRARY_PATH=/usr/lib:/usr/X11R6/lib:$LD_LIBRARY_PATH
    export LD_LIBRARY_PATH
    export DISPLAY=:0.0
    unset USERNAME

    Next:-

    [orauser@ServerORCL ~]$ tar xvf tora-1.3.18.tar
    [orauser@ServerORCL ~]$ cd tora-1.3.18
    [orauser@ServerORCL ~]$./configure --with-qt-dir=/usr/local/qt --with-instant-client
    [orauser@ServerORCL ~]$ make

    As root:-

    # cd ~orauser/tora-1.3.18
    # make install

    As orauser:-

    Add export MALLOC_CHECK_=0 to .bash_profile and relogin.
    to avoid crashing like :-

    *** glibc detected *** double free or corruption (!prev): 0x09acad08 ***

    when running binary /usr/local/tora/bin/tora

    Regarding glibc issue :-

    The version of glibc provided with CentOS 4.1 performs additional internal sanity checks
    to prevent and detect data corruption as early as possible. By default, should corruption
    be detected, a message similar to the following will be displayed on standard error
    (or logged via syslog if stderr is not open):

    *** glibc detected *** double free or corruption: 0x0937d008 ***

    By default, the program that generated this error will also be killed; however, this (and whether or not an error message is generated) can be controlled via the MALLOC_CHECK_ environment variable. The following settings are supported:

    0  Do not generate an error message, and do not kill the program
    1  Generate an error message, but do not kill the program
    2  Do not generate an error message, but kill the program
    3  Generate an error message and kill the program

    Note:

    If MALLOC_CHECK_ is explicitly set a value other than 0, this causes glibc to perform more tests that are more extensive than the default, and may impact performance.Should you have a program from a third party ISV that triggers these corruption checks and displays a message, you should file a defect report with the application's vendor, since this indicates a serious bug.