While I was waiting for my message to be approved, I got a solution on the IRC channel. It turns out that in the Arch Linux update I ran, it rendered a portion of my fstab config deprecated. I just had to delete the line defining /dev/pts and all is working again.

On Sat, Aug 24, 2013 at 5:03 AM, Thomas Adam <thomas@xteddy.org> wrote:
On Thu, Aug 22, 2013 at 10:16:02PM -0500, Benjamin Bergman wrote:
> I'm running Arch Linux and I just ran some updates and rebooted. I tried
> running tmux and it exits immediately after printing some strange
> characters to the screen. Some examples:
> /62;9;c_
> [>4m^[[?62;9;c
> The 62;9;c is there pretty much every time. In addition to this, most times
> I try to run tmux, it breaks my terminal session and I need to run `reset`
> to get things sorted again. By 'breaks' I mean that if I do something like
> `ls -la` new lines are aligned to the end of the previous line instead of
> to the left of the screen.
> Any and all suggestions are welcome.

What is TERM set to inside/outside of tmux?  Do you have any
terminal-override settings in your .tmux.conf?

-- Thomas Adam

"Deep in my heart I wish I was wrong.  But deep in my heart I know I am
not." -- Morrissey ("Girl Least Likely To" -- off of Viva Hate.)