tkcvs problem on solaris

Help
danfel
2005-07-14
2013-04-17
  • danfel
    danfel
    2005-07-14

    Hi All!
    I have installed tkcvs 7.2.3 on solaris 5.8.
    I succeed to browser Module by repository
    but I have the problem with checkuot or export or update ecc operation(not work).
    I select the module on repository.
    I select local directory.
    I set the options checkout.
    I Try to perform the operation AND I have the message:
    "This will check out queuesat from CVS. Are you sure?"
    I click Ok button but anything does not happen(he does not work ).

    Someone could help me?

    NB: The log trace is OK..

    Thank you

     
    • DorothyR
      DorothyR
      2005-07-14

      I noticed something like that yesterday.  Don't know what it is yet but  I think it's a new bug.  Will post more info as soon as I get it.

      -d

       
    • danfel
      danfel
      2005-07-15

      Dorothy Thanks for the immediate answer.
      If it can help you  I have installed tkcvs 7.2.3 on Windows XP AND I have the same problem.

      I can download an old working version??
      What advises me for Solaris??

      Thank you

       
      • DorothyR
        DorothyR
        2005-07-15

        You can download older versions from http://sourceforge.net/project/showfiles.php?group_id=3310

        I tried to duplicate the problem on Solaris yesterday and wouldn't you know, everything worked fine.  So I'm still clueless.

         
    • danfel
      danfel
      2005-07-15

      Dorothy
      Thanks Again for the interest!!!
      I have installed tkcvs 7.2.2 on solaris 5.8. AND WORK FINE!!

      I continue to monitorig the tkcvs  website for the news.

      Thank you very much

       
    • DorothyR
      DorothyR
      2005-07-15

      Found the problem.  It's the confirmation dialog - if you go to Options and uncheck Confirmation Dialog, the checkout will work. The tk_messageBox dialog returns a different value than the old tk_dialog did, and I wasn't checking it correctly.

      I checked in these 3 files:
      cvs.tcl
      errors.tcl
      workdir.tcl

      If you get the new files, it should fix the problem.