mingw32 compile errors

  • daddydave

    I am using wx-devcpp and mingw with gcc version 3.4.2. I imported the .dsp file into wx-devcpp and created tinyxml.a (I tried with and without main.cpp and htmlutil.cpp)

    I then open up another new project with just main.cpp and htmlutil.cpp, or just main.cpp and try to compile it so I can see the regression testing. I tried adding tinyxml.a by browsing to it but when I try to make the .exe, I get errors. the tinyxml.a was originally in c:\tinyxpathbut then I moved it to c:\tinyxpath\tinyxpath_lib
    Compiler: Default compiler
    Building Makefile: "C:\dave\devproj\tinytest\Makefile.win"
    Finding dependencies for file: C:\dave\devproj\tinytest\..\..\..\tinyxpath\main.cpp
    Executing  make...
    make.exe -f "C:\dave\devproj\tinytest\Makefile.win" all
    g++.exe ../../../tinyxpath/main.o  -o "tinytest.exe" -L"C:/Dev-Cpp/lib" -L"C:/tinyxpath" -lwxmsw26 -lwxmsw26_gl -lwxtiff -lwxjpeg -lwxpng -lwxzlib -lwxregex -lwxexpat -lkernel32 -luser32 -lgdi32 -lcomdlg32 -lwinspool -lwinmm -lshell32 -lcomctl32 -lole32 -loleaut32 -luuid -lrpcrt4 -ladvapi32 -lwsock32 -lodbc32 -lopengl32 ../../../tinyxpath/tinyxpath_lib/tinyxpath.a 

    ../../../tinyxpath/main.o(.text+0x44):main.cpp: undefined reference to `TinyXPath::S_xpath_string(TiXmlNode const*, char const*)'
    ../../../tinyxpath/main.o(.text+0x56):main.cpp: undefined reference to `TiXmlString::operator=(TiXmlString const&)'
    ../../../tinyxpath/main.o(.text+0x189):main.cpp: undefined reference to `TiXmlDocument::TiXmlDocument()'
    ../../../tinyxpath/main.o(.text+0x19b):main.cpp: undefined reference to `TiXmlDocument::LoadFile(char const*)'
    ....(also a lot more of the same....)

    I guess the dsp didn't import exactly right, dev-cpp uses .dev files natively. Any ideas on what I should do next?

    Should I have downloaded and linked TInyXML first? TinyXPath seems to include it

    • daddydave

      UPDATE: This is now resolved. I noticed my tinyxpath.a file was only 8 bytes in size, so I ignored the dsp file and just made a new regular wx-Devcpp project with all the cpp files, got a 301KB file, and was able to compile the regression tests.