Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Error on Timidity configuration

Help
2008-05-23
2013-05-08
  • I don't know if anybody has the same problem, but after installing TiMidity on Ubuntu Linux 8.04 I get this error:

    "ALSA lib pcm.c:2105:(snd_pcm_open_conf) Cannot open shared library plugindir/libasound_module_pcm_pulse.so
                                                                             [fail]
    invoke-rc.d: initscript timidity, action "start" failed."

    After this, TiMidity works but as it isn't totally configured, I get this error every time I install something or run "dpkg --configure -a".
    I get the same error when I run "/etc/init.d/timidity restart". This seems to be just an error on /etc/init.d/timidity, since running manually

    "start-stop-daemon --start --quiet --exec /usr/bin/timidity  --pidfile /var/run/timidity.pid -- -B2,8 -iAD"

    doesn't gives me any error, and starts a TiMidity JACK session.

    I didn't have any of these problems on Ubuntu 7.04 (probably due to the new PulseAudio sound manager, which may not be supported by TiMidity).

     
    • I think you should install libasound2-plugins to get that file.

       
    • Thanks, but I already have it installed.

      For now, I have edited /etc/init.d/timidity like this:

      [...]
      case "$1" in
        start)
          start-stop-daemon --start --quiet --exec /usr/bin/timidity --pidfile /var/run/timidity.pid -- -B2,8 -iAD
          exit 0
          ;;
        stop)
      [...]

      and at least it works, and doesn't throw any annoying error (due to the "exit 0" line).

       
    • Never mind; it was an ALSA problem.
      Fixed it by editing .asoundrc and commenting a line that got misteriously uncommented.