#1393 Changing forum topic name results in one topic shown

v1.8
open
nobody
5
2004-03-30
2004-03-20
Terris Linenbach
No

1. Add a new topic to a forum.
2. Add another topic to a forum.
3. Reply to the topic.
4. Go to the forum list.
5. Click on the forum.
6. Click on the new topic you added in 2
7. Modify the name of the topic and click post.

Result:
The list of topics for the forum are shown. The list
only contains one entry, the new topic name you entered.

Discussion

  • Logged In: YES
    user_id=155319

    Revised list of steps

    1. Add a new topic called foo
    2. Add another topic called bar
    3. Go to the forum's topic list
    4. Click on the topic bar
    5. Click on the edit icon
    6. Change the name of the topic to zap
    7. Click post

    Result: Forum topic list only contains one topic: zap.
    The foo topic will be shown if you click on the forum name
    at the top of the page.

     
    • labels: --> Feature Partially Broken
     
    • milestone: --> v1.8
    • summary: Changing forum topic name results in one forum topic --> Changing forum topic name results in one topic shown
     
  • Logged In: YES
    user_id=738765

    Hi,
    when you say topic bar, do you mean the "new topic" button"?

     
  • Logged In: YES
    user_id=155319

    I mean topic "bar" - the topic named bar.

     
    • status: open --> open-works-for-me
     
  • Logged In: YES
    user_id=738765

    Sorry about that "sleepy" reply.
    I can't reproduce this with 1.8CVS and 1.8.0.

     
  • Logged In: YES
    user_id=155319

    I can reproduce this on tw.o. Just modify a post that has
    no replies. The posts added after the post you modify
    aren't shown after you click "post" to modify it (but other
    posts are shown).

    Unrelated bug.. I can't actually modify my post on tw.o but
    this bug still manifests itself.

     
    • status: open-works-for-me --> open
     
  • Logged In: YES
    user_id=738765

    OK, I could get this on tw.o. I would describe "Ulterior
    topics sometimes hidden after forum thread edit"
    Indeed, I wasn't able to reproduce this easily, even testing
    with the same topic.