#1151 Wikiword in description field breaks Wikilinks to it

All_versions
open-accepted
nobody
5
2004-08-27
2004-01-05
No

Starting point: Wiki page with the following source
----------- start of Wiki page
-=Current Newsletter=-
* NewsletterDecember

-=2003=-
* NewsletterNovemberFormatTiki

-=Prior Newsletters=-
All newsletters prior to Nov 2003 are here:
[https://somedomain.com/somedirectory/MonthlyNewslet
ter.html]
----------- end of Wiki page

The referenced page NewsletterNovemberFormatTiki
contains the following Description:

November 2003 Newsletter (By SaR Monday, November
24, 2003 )

SAR is defined as a Hotword (pointing towards this
person's UserPage).

Result:

the page is shown as follows (bug in 2003 paragraph):
------------- start display
Current Newsletter

* NewsletterDecember

2003

* SAR Monday, November 24, 2003 )" href="tiki-
index.php?page=NewsletterNovemberFormatTiki"
class="wiki">NewsletterNovemberFormatTiki

Prior Newsletters

All newsletters prior to Nov 2003 are here:
https://somedomain.com/somedirectory/MonthlyNewslett
er.html
----------- end of display
(Note: SAR is correctly underlined as it is a Hotword
Link).

Diagnosis:
the Hotword replacement mechanism erroneously kicks in
when a page is referenced *and* its Description field
contains a Hotword.

Workaround:
don't use Hotwords in Description fields... :)

Discussion

  • Logged In: YES
    user_id=738765

    Third time I see that, thx for the bug report ;)
    The two first times were using WikiWords instead.

     
    • summary: Wiki: Hotword in Description field => link resolution NOK --> Hot/Wikiword in Description field breaks Wikilinks to it
    • status: open --> open-accepted
     
  • ben
    ben
    2004-01-08

    Logged In: YES
    user_id=752226

    same for me.
    is it fixed in 1.7.4 or later?

     
  • Logged In: YES
    user_id=738765

    I'd be very surprised

     
  • Logged In: YES
    user_id=944067

    uh, I'm currently using v1.7.4 - that's what the Group field is
    all about, no? ;)

     
  • Logged In: YES
    user_id=738765

    mose should have fixed the Hotword part of the bug.

     
  • Dennis Daniels
    Dennis Daniels
    2004-06-04

    • status: open-accepted --> closed-out-of-date
     
    • summary: Hot/Wikiword in Description field breaks Wikilinks to it --> Wikiword in description field breaks Wikilinks to it
    • milestone: 350658 --> All_versions
    • status: closed-out-of-date --> open-accepted
     
  • Logged In: YES
    user_id=738765

    Reopened since present in 1.9 CVS, although it only affects
    WikiWords now.
    Note that to reproduce this you must use a WikiWord.
    For example linking with "TestTest" will break but linking
    with "((TestTest))" will work well (and could constitute a
    workaround for now).