#1044 Dynamic variables : Blank field sometimes shows by default


I just realized this was implemented :)
And got first bug with it too ;)
Ending a Wiki page with (respect line break)
results in the value of %varname% to display on the
first line, and on the second a blank field even
without clicking to edit. It looks like it's not
possible to edit the variable when the bug occurs.
It's not 100% reproducable (probably that there are
other conditions necessary) but I got it both on my own
Tiki using day-fresh CVS and on tw.o also quite fresh
(see Sandbox's bottom maybe :p).
Here, the line after %varname% contains three spaces,
but I suppose other content could trigger it too.


  • Dennis Daniels
    Dennis Daniels

    • status: open --> pending-out-of-date
  • Logged In: YES

    Please try to reproduce on current 1.8CVS instead.

    • milestone: 316038 --> v1.8RC
    • status: pending-out-of-date --> open
  • Logged In: YES

    This is a broadcast message for all open bugs left before 2004/01/05.
    We hope it was checked but no bug update took place.
    The bug you reported may have been fixed.
    Additionally, if you are using an older form of TikiWiki,
    it is highly recommended you update at least to 1.8.5
    with new security fixes.

    So we open a procedure over the 2 next weeks:
    Please, check your bug or request.
    If you feel it's not relevant anymore, then close it.
    But, if you mind it's still current,
    we invite you to open a new fresh request.

    At the end of this period,
    an automatic cleaning with notifications will take place.

    Tikily yours,
    Tikiwiki Bugs Cleaners
    (contact ---> toggg)

    • status: open --> closed