Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

SVN 1006 does not start

TXS - Help
2010-07-01
2012-10-17
  • Pat Schweitzer
    Pat Schweitzer
    2010-07-01

    Hello,
    I know this is a pretty scarce error report, but after do a

    svn up
    qmake texmakerx.pro
    make
    sudo make install

    the programm usually opens. Now I just see the popup windows saying texmakerx.
    Then it gives a segmentation fault and it shuts down. I also tried BUILD.sh,
    but that isn't working as well.

    I am using Ubuntu 9.10. Is that a known problem?
    Thanks,

     
  • you could try a "make clean" before qmake ...

     
  • Pat Schweitzer
    Pat Schweitzer
    2010-07-01

    I tried make clean, but it does not work. I even updated to Lucid 10.04 now,
    still does not work. I'd really appreciate any ideas...

     
  • okay, normally the gnu debugger is installed.

    try:
    make clean
    make debug
    run the generated texmaker in the debugger: gdb ./texmakerx
    type "run" inside the debugger.
    You should get a backtrace if texmakerx crashes which you can send us.
    (more comfortable is using qtcreator instead if you have some knowledge in
    using IDEs)

     
  • Pat Schweitzer
    Pat Schweitzer
    2010-07-01

    Here's the output.

    Starting program: /../private/texmakerx/trunk/texmakerx

    Program received signal SIGSEGV, Segmentation fault.
    0x080d419a in LatexEditorView::documentContentChanged (this=0x8d05a38,
    linenr=0, count=1) at latexeditorview.cpp:548
    548 if (editor->languageDefinition()->language()!="(La-)Tex") return; // no
    online checking in other files than tex

    I'm not a programmer, so I did not use qtcreator. Some language related
    problem...
    Thanks for your efforts so far, you are great!

     
  • okay, do start texmakerx, does it load any documents ? (or used it to load
    documents to restore a session)
    if yes, what kind of documents ?
    Does it directly crash or after some user interaction ?

    (if you want to get rid of the crash, you can comment out the above mentioned
    line by inserting "//" at the start of that line...)

     
  • by the way, you could run another gdb-Session and now type "bt" after the
    crash to get a little more info

     
  • i checked in a new version.
    could you updated and try out whether it still crashes ?

     
  • Pat Schweitzer
    Pat Schweitzer
    2010-07-01

    :-) You solved it! Now it starts again.
    Not sure if it is still relevant, texmakerx did not load any documents, but I
    sure use the restore command. It should have opend (and does now again open) 3
    tex documents (.sty, .tex and .bib). Oh and yes I am using some Umlauts (I
    guess.).

    Thanks again.
    A happy guy going home now.