Two problems on Linux SVN-938

TXS - Help
2010-05-28
2012-10-17
  • Pat Schweitzer
    Pat Schweitzer
    2010-05-28

    Hi,
    first of all I want to say, I love TexMakerX. It's really great.

    Second, I came across two bugs, I'm note sure whether I'm the only one with
    them.
    I'm on Ubuntu 9.10 and compiled a version from the svn using qmake, make and
    makeinstall. (SVN: 938).

    • When I type \ref TexMakerX dies immediately without saving anything.
    • After editing the .tex file, using the shortcuts F1or F2 (Quick Build / Compile) opens a new tab (sometimes several new tabs) named untitled and a "save as" dialog pops up. (Even though it already has a file name.) Closing the save as dialog, closing the
      tabs "untitled" and pressing the F2 again then works without any problems.

    I tried the .deb 1.9.9 SVN 898M version. This version does not have these
    problems.

    Thanks for your help.

     
  • okay the crash is fixed (though not the intentional behaviour which led to the
    crash)

    however i can't reproduce the second issue. What exactly do i need to do to
    see the problem.

     
  • Pat Schweitzer
    Pat Schweitzer
    2010-05-31

    Thanks :-)

    I couldn't reproduce the error with the SVN949 myself. It's strange bug and I
    haven't really understood when it occurs.
    I'll continue using the development version and report back if the problem
    occurs again.

    One happy user.

     
  • Pat Schweitzer
    Pat Schweitzer
    2010-06-01

    Hello again,
    just found another bug, I belive.
    I open a file already opened in TexMakerX with another program. Then I edit
    the file with the other program and save it
    with the other program. Clicking back into the TexMakerX Window, TMX then asks
    if I want to keep up to date by reloading the file. If i press Yes, TMX
    crashes.

     
  • Pat Schweitzer
    Pat Schweitzer
    2010-06-01

    Hello again,
    I finally managed to reproduce the bug I mentioned in post 1. Now, I am not
    sure if it's only me, but here it is. I use xdvi, together with the following
    command (that executes F2):
    xdvi -editor "/home/ubadmin/private/texmakerx/trunk/texmakerx %f -line" %.dvi
    -sourceposition @:%.tex

    Whenever I do inverse search (hit CTRL + mouse) to jump back from xdvik to
    TMX, it opens a new "untitled" windows in TMX. It does not get active and I
    can work normally, until I want to compile TeX again, which of course prompts
    the above mentioned
    save as dialoge.
    Any ideas? Thanks,

     
  • This command works:
    xdvi -editor "/opt/texmakerx/texmakerx %%f --line %%l" %.dvi -sourceposition
    @:%.tex

    %% is necessary to get a % instead of the file name, and %l is necessary to
    get the line separately (if %l is missing xdvi doesn't give the file with %l
    but file+linenumber which tmx doesn't understand ).

     
  • Pat Schweitzer
    Pat Schweitzer
    2010-06-02

    Oops,
    I feel stupd now. It's written quite large on the page, I have to admit.
    Sorry. Thanks for telling me.
    What about the bug from post 4?

    I open a file already opened in TexMakerX with another program. Then I edit
    the file with the other program and save it with the other program. Clicking
    back into the TexMakerX Window, TMX then asks if I want to keep up to date by
    reloading the file. If i press Yes, TMX crashes. (In other words, it's not
    working with amongst others svn.)

     
  • that should be fixed in the latest svn revision

     
  • Pat Schweitzer
    Pat Schweitzer
    2010-06-03

    Cool,
    I just checked it out and it works like a charm! Thank you so much :-)