Switching from TeXworks to TeXstudio

TXS - Help
Keyes
2013-08-29
2013-08-29
  • Keyes
    Keyes
    2013-08-29

    Hi,
    until recently, my company has been working with Texworks as an editor and compiler. Since we are missing a few features, we thought about switching to TXS. We´re using latex for our user manuals.
    Using Texworks, we only had to add three arguments to our “custom” typesetting (pdflatex.exe):
    $fullname
    $synctexoption
    --jobname=$basename_de_73_
    This way, we are able to compile several, multi-language documents based on one master document. Thus, if we change --jobname=$basename_de_73_ to --jobname=$basename_en_73_, we only compile those sections that have been tagged with \tags{en} and the PDF is automatically named after the $basename
    This is an example of our master documents:

    \documentclass{../../documentclass}
    \begin{document}
    Title
    {\parskip0.5ex
    \tableofcontents
    }
    {\parskip0.5ex
    \listoffigures
    }
    \pagebreak
    typographical conventions
    \tags{de}{\input{some German input}}
    \tags{en}{\input{some English input}}

    \end{document}

    As you can see, we came up with our own custom commands, located in our document class.
    As mentioned before, configuring Texworks only required adding those three arguments and downloading the respective packages. Basically, I could configure Texworks by simply replacing the existing config file.
    However, configuring TXS seems to be more complex. So far, I was only able to implement a language switch using the –jobname=$basename command. However, I didn´t manage to rename the PDF according to the $basename. Also, TXS keeps displaying that it doesn´t know my custom commands (even though their applied correct).
    This is what I entered into the command line
    pdflatex -interaction=nonstopmode -synctex=1 -include-directory=dir -jobname=$basename_de_73_%.tex

    Maybe you can help me.

    Greetings,
    Daniel

     
  • I guess what you want is:

    pdflatex -interaction=nonstopmode -synctex=1 -include-directory=dir -jobname=%de_73 %.tex

    if your commands are defined in "dir/includedFiles" txs can't read them and consequently does not know them.
    So either you place the included files in the same base directory as your mainfile, or you include the files with filenames relative to that base directory or you define a cwl file and load it in the options (see manual).

     
    • Keyes
      Keyes
      2013-08-29

      pdflatex -interaction=nonstopmode -synctex=1 -include-directory=dir -jobname=%de_73 %.tex worked !

      All of our files are inclueded using relative paths, e.g.

      \tags{en}{
          \input{administrations_handbuch_en/0100_vorwort.tex}
      

      However, getting the file name right was the main issue. I´ll check the manual for defining custom commands in txs.

      Thanks