How to disable on-the-fly installation dialog when opening a document?

TXS - Help
U_Fischer
2013-11-06
2013-11-07
  • U_Fischer
    U_Fischer
    2013-11-06

    When I open a document in texstudio which loads packages which are not installed the on-the-fly-installation dialog of miktex appears. How can I disable this? I only want to look at the document and decide about installation later!

    Ulrike Fischer

     
  • Tim Hoffmann
    Tim Hoffmann
    2013-11-06

    That's a bit strange. It would imply that miktex is called when loading the document. I'm not aware that this should happen (except maybe because of a preview). Moreover, I wasn't able to reproduce it here. Could you provide a minimal example (i.e. a short example document and the not-installed package name).

     
  • U_Fischer
    U_Fischer
    2013-11-06

    I created this example document in an external editor:

     \documentclass{article}
     \usepackage{bg}
     \begin{document}
      blub
     \end{document}
    

    When I open it in texstudio the miktex installation dialog pops up and asks me if I want to install the backammon package (I have set the on-the-fly to "ask me first"). If I close the file and reopen it the dialog doesn't appear again. But closing texstudio and reopen it triggers it again. The setting in "Editor / Interaktives Überprüfen / Paket" (no idea how it is called in english) does not change the behaviour.

    Ulrike Fischer

     
  • Eyzel
    Eyzel
    2013-11-07

    This even happens when you just paste Ulrike's example in a new document within TXS. Actually, it appears when you just type \usepackage{bg} in any open document. Like Ulrike said, when I close the dialog by pressing 'Cancel' the dialog doesn't appear again for that package in the current session. (Of course it does appear again when manually running a TeX engine in TXS.) Also, when I enter another package that is not installed (e.g. \usepackage{xyling}) it immediately pops up again.

    Apparently, TXS continuously checks in the background for missing packages when you type \usepackage{...} by calling some MikTeX executable that causes the dialog to appear. And it keeps a list of the packages it already checked in memory for the current session. But this should be possible to turn off indeed.

     
    • txs scans the packages to get syntax information on the provided commands.
      This is legit, however miktex pops dialog boxes from non-interactive
      commands. This is rather a miktex problem/bug.

      We can build in some work-arounds on this non-standard behavior, but the
      scanning will not be disabled as otherwise the whinning starts again:
      "why is the valid command marked as syntax error ..."

      On 07.11.2013 17:03, Eyzel wrote:

      This even happens when you just paste Ulrike's example in a new document
      within TXS. Actually, it appears when you just type \usepackage{bg} in
      any open document. Like Ulrike said, when I close the dialog by pressing
      'Cancel' the dialog doesn't appear again for that package in the current
      session. (Of course it /does/ appear again when manually running a TeX
      engine in TXS.) Also, when I enter another package that is not installed
      (e.g. \usepackage{xyling}) it immediately pops up again.

      Apparently, TXS continuously checks in the background for missing
      packages when you type \usepackage{...} by calling some MikTeX
      executable that causes the dialog to appear. And it keeps a list of the
      packages it already checked in memory for the current session. But this
      should be possible to turn off indeed.


      How to disable on-the-fly installation dialog when opening a document?
      https://sourceforge.net/p/texstudio/discussion/907840/thread/590f62db/?limit=25#ef14


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/texstudio/discussion/907840/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

       
      • U_Fischer
        U_Fischer
        2013-11-07

        I agree that kpsewhich shouldn't start the on-the-fly installation. On the other side kpsewhich is not an official tool of miktex it exists only (like texdoc, updmap and other texlive alias commands) as a courtesy, the official tool to find files is findtexmf. I also understand that you don't want to disable the analysing by default. But couldn't you offer some well hidden expert option to suppress it temporarly?

         
        • I beg to differ.
          The official tool is kpsewhich, findtexmf does not exist on texlive.

          By the way, you can disable on the fly installation in your
          miktex-installation, can not you ?

          I will probably build in a work-around for miktex but this will take
          some time before it reaches the official builds.

          On 07.11.2013 18:12, U_Fischer wrote:

          I agree that kpsewhich shouldn't start the on-the-fly installation. On
          the other side kpsewhich is not an official tool of miktex it exists
          only (like texdoc, updmap and other texlive alias commands) as a
          courtesy, the official tool to find files is findtexmf. I also
          understand that you don't want to disable the analysing by default. But
          couldn't you offer some well hidden expert option to suppress it
          temporarly?


          How to disable on-the-fly installation dialog when opening a document?
          https://sourceforge.net/p/texstudio/discussion/907840/thread/590f62db/?limit=25#ef14/9df0/e037


          Sent from sourceforge.net because you indicated interest in
          https://sourceforge.net/p/texstudio/discussion/907840/

          To unsubscribe from further messages, please visit
          https://sourceforge.net/auth/subscriptions/

           
  • a workaround has been implemented in the repository

     
    • U_Fischer
      U_Fischer
      2013-11-07

      Christian Schenk has answered to my miktex bug report: One can disable the autoinstall with kpsewhich by setting this environment variable:

      set MIKTEX_KPSEWHICH_MPM_AUTOINSTALL=no

      I tested it, it works fine.

      Ulrike Fischer