Tutorial for compiling a SVN in Windows?

TXS - Help
  • iceman01

    I know that on Unix systems compiling is fairly easy, but I have to use
    Windows. I downloaded Qt and tried to compile an SVN without success.
    As there are compiled versions in the repository, there must be a developer
    who compiles in Windows., it would be really, really kind if you could provide
    a Tutorial/HowTo for compiling in Windows, including the software that needs
    to be installed

  • ERROR! The markdown supplied could not be parsed correctly. Did you forget to surround a code snippet with "~~~~"?

    I have written a little about compiling tmx.  
    Take a look and please state whether this is helpful...  
  • iceman01

    I'm quite busy at the moment, but I'll test it and post a comment as soon as
    the workload reduces.

  • iceman01

    I gave it another try, but about 30 issues popped up when I compiled it. Too
    many to do the debugging each time a new SVN is released.

  • well, things have been simplified. So now, only the include paths for poppler
    need to be set correctly.
    Source should compile as it is.
    And if it compiles once, it always compiles after svn updates, at least here.

  • iceman01

    I tried again this morning, using NO_POPPLER=true and having MinGW installed.
    Worker like a charm. I will try to do it with poppler this evening and post
    the results.
    I don't really know if it is necessary to have MinGW installed, but if it is
    necessary, it should be added to the Tutorial in the Wiki.

    P.S. You do a great job, improving and adding new features!!

  • iceman01

    I forgot to mention that it would be good to have the option
    NO_POPPLER_PREVIEW mentioned in the Wiki.

  • iceman01

    I just downloaded and tried to compile. Compiling canceled with error message
    "zconf.h: no such file or directory". I tried to edit the file zlib.h by
    changing the path of zconf.h to "C:\Qt\2010.05\qt\src\3rdparty\zlib". But it
    didn't work either.
    Using the "NO_POPPLER_PREVIEW=true" option, compilation without Poppler still
    works fine.

  • i can't try it out now, but try to copy zconf.h into include_win32 ...

  • iceman01

    I already tried, it solves the problem with zconf.h being missing, but
    compiling is canceled with an error. I guess there are some more files to be
    added to the include_win32 folder. But there is no lzlib on my system that I
    could copy there.
    Last part of the log file:

    c:/qt/2010.05/mingw/bin/../lib/gcc/mingw32/4.4.0/../../../../mingw32/bin/ld.exe: cannot find -lzlib
    collect2: ld returned 1 exit status
    mingw32-make[1]: Leaving directory `C:/Users/Marc/Desktop/TexmakerX SVN/texmakerx-build'
    mingw32-make: Leaving directory `C:/Users/Marc/Desktop/TexmakerX SVN/texmakerx-build'
    mingw32-make[1]: *** [texmakerx.exe] Error 1
    mingw32-make: *** [release] Error 2
    Der Prozess "C:/Qt/2010.05/mingw/bin/mingw32-make.exe" wurde mit dem Rückgabewert %2 beendet.
    Fehler beim Erstellen des Projekts texmakerx(Ziel: Desktop)
    Bei der Ausführung von Build-Schritt 'Make'
  • that is where the copying of the dlls come into play.

    Take from an recent tmx installation (2.0) all dll and copy them into the
    source directory.
    (ld is the linker)

  • iceman01

    I haave all 19 dlls in the following directories:
    directory with files from the SVN,
    directory in which texmakerx.exe is build.
    I even tried to adapt the texmakerx.pro. I changed -lzlib to -lzlib1, as the
    dll in the TexmakerX directory is named lzlib1.dll. Maybe there are more
    references to this file that need to be changed?
    Anyway, what else am I missing/doing wrong?

  • -lzlib is okay.

    dll should be placed in the source directory (let's call it texmakerx)
    Have turned off "shadow build" (Qt Creator , Build/Project)

  • iceman01

    Shadow build was on, turned it off but same error. Just to make sure I get it
    right. By source directory you mean the directory where I place the files that
    I download from the SVN? In my case it is "C:\Users\Marc\Desktop\TexmakerX
    SVN\SVN" when I disable shadow build Qt will build in this directory. So I
    place the files from the SVN and the dlls in this directory and hit the build

  • i suppose texmakerx.pro is located in the SVN directory.
    Do you start "rebuild project" afte doing the changes ?
    what error do you get now ?

  • iceman01

    Same error as before, cannot find -lzlib, with or without shadow build and no
    matter where I place the dlls. There must be something I'm doing wrong.

  • -lzlib means it can't find the libraty zlib.
    You should have a file called something like zlib.lib, zlib.a, libzlib.a,
    libz.a (<- latter on linux ) ...

  • iceman01

    When I enter the absolute link to the .dll it works. My problem is that I
    don't have the .a files, where can I get them?

  • i believe that the problem is basically sorted out.
    whyever it does not recognize the dll directly is a little unclear as it works
    here (maybe it could be renamed ?), but going to hunt for libzlib.dll.a is not
    really helpful (as winkde seems not to offer them).

  • iceman01

    I think so, too. But you should add a note to the wiki.