Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Automatic Follow

TXS - Help
2011-04-28
2012-10-17
  • Pat Schweitzer
    Pat Schweitzer
    2011-04-28

    Hey,
    I am not sure about this, but I believe this is some kind of new feature that
    doesn't work properly.
    I'm on TMX SVN 1917, Ubuntu 10.04. Here's the "problem"

    I open a .tex file and work a bit. After a while it autosaves. After another
    while TMX starts compilation.
    Then I get the following messages in the message window.

    Process started: latex -interaction=nonstopmode -ini "&latex hik3469 \dump"

    Process exited with error(s)

    Process started: latex -interaction=nonstopmode -src-specials -synctex=-1
    "ZT3469".tex

    Process exited with error(s)

    Process started: dvipng -T tight -D 120 "ZT3469".dvi

    Process exited with error(s)

    Now I am guessing this stems from the Segment preview, right?
    I tried numerous configuration options, but none seem to work. I even seem to
    be unable to turn the whole thing off.
    (I tried Auto preview: Never but it wouldnt stop trying to compiling every now
    and then)

    Do you have any insights on that?
    G'day

     
  • Pat Schweitzer
    Pat Schweitzer
    2011-04-28

    Oh, I forgot to mention that in the "log file" and the "error" tabs, I still
    see the messages from the last non-automatic latex run. That's why I am
    posting this under help and not as a flaw. I don't know where to find the
    error messages.

     
  • you have not used the inline preview feature by any means ?
    Because it has an auto update mechanism ...

     
  • apart from that if you hove over a math equation (the $ or begin{euation},) a
    preview is triggered ... (that can be turned off as well in the svn version)

     
  • Pat Schweitzer
    Pat Schweitzer
    2011-04-29

    No, it's not the inlein preview feature. How does that work / where do I turn
    that on?

    After some playing around, I am sure it's the "hover over math equation"
    thing. So now that question.
    Why doesn't that work or maybe more to the point, where do I find error
    messages why it doesn't work.

     
  • Pat Schweitzer
    Pat Schweitzer
    2011-05-02

    Thanks, that was the hint I needed. (At least I know now, where to turn it
    off.)
    I also found the log-file and confirmed that using the import package (more
    specifically the \subimport command) causes the problem. Are there and
    prospects on fixing this?
    I tried to add an additional path to my environment, but it seems subimport
    doesn't even check whether the file is already there.