Compiling TXS using qt5 OSX10.9

TXS - Help
Robert
2013-11-20
2013-11-20
  • Robert
    Robert
    2013-11-20

    Hi All. I was wondering if someone can help me and tell how to compile TXS using qt5. I installed qt5 using homebrew. For a qt4 compilation, running sh build.sh in terminal guides me nicely through the process but it doesn't give me the option of choosing qt5.

    Do I need to do something with my poppler installation (also with homebrew)? For qt4, I know I have to use
    brew install poppler --with-qt4 --enable-xpdf-headers
    but I am not sure about qt5 in this area as well?

    What do I need to do to compile for qt5? Any lines I need to modify files such as texstudio.pro?

    Thanks!

     
    • Easiest way is using qt-creator and using the build system there.
      Apart from that using qt5-qmake should be sufficient

      qmake texstudio.pro
      make

      On 20.11.2013 20:54, Robert wrote:

      Hi All. I was wondering if someone can help me and tell how to compile
      TXS using qt5. I installed qt5 using homebrew. For a qt4 compilation,
      running sh build.sh in terminal guides me nicely through the process but
      it doesn't give me the option of choosing qt5.

      Do I need to do something with my poppler installation (also with
      homebrew)? For qt4, I know I have to use
      brew install poppler --with-qt4 --enable-xpdf-headers
      but I am not sure about qt5 in this area as well?

      What do I need to do to compile for qt5? Any lines I need to modify
      files such as texstudio.pro?

      Thanks!


      Compiling TXS using qt5 OSX10.9
      https://sourceforge.net/p/texstudio/discussion/907840/thread/21cd5b53/?limit=25#b440


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/texstudio/discussion/907840/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/