log file parsing (multiple includes)

2011-08-24
2012-10-17
  • Hi,

    I am compiling a large document. I have a main file (book.tex), and several
    other files which contain the actual content (chapt1.tex, chapt2.tex, etc.).
    In the main file, I use the include command: \include{chapt1}, etc. to include
    all the parts.
    I can compile no problem using pdflatex, and a pdf is produced as I expect.

    However, there is something wrong with the parsing of the logfile. When I
    click the "errors" tab at the bottom of the main window in an effort to
    examine the various "bad box" warnings, it shows that ALL the errors are in
    book.tex, and most of them are on "line 0". It doesn't seem to correctly
    reference the sub-files in which the errors are actually located. The errors
    are not descriptive at all either. Items such as:

    File: book.tex
    Type: bad box
    Line: line 0
    Message: Underfull \vbox (badness 10000) has occured while \output is active

    Each item on the list is a link, but clicking the link doesn't take me
    anywhere (not surprising... it's probably trying to find line 0 of
    book.tex...). And I don't know where the errors actually are.

    Is this a bug in TexStudio? or is there a special way I should be compiling
    these multi-file documents that will lead to a more useful error report?

    thanks

     

  • Anonymous
    2011-11-15

    Hi,

    I'm facing the same problem and I want to add that this occurs with \input,
    too. Is there any solution to fix this problem?

     
  • please check if the option is checked:

    options/ activate advanced options

    options/quick build/Assume that every error is in the current document ->
    never

     

  • Anonymous
    2011-11-16

    Thank you for your reply, jsundermeyer.
    I already tried changing these options, but unfortunately it didn't work.

    I created a minimal example:
    HelloWorld.tex:

    \documentclass{article}
    
    \begin{document}
    Hello World
    \include{Chapter1}
    \end{document}
    

    Chapter1.tex:

    Hello
    World \ref{notExisting}
    

    Result:

     
  • works fine here.
    Have you changed the pdflatex command ? (or which command do you use ?)
    Can you post the log file ?

     

  • Anonymous
    2011-11-16

    Hello!
    I had the same problem too - every error and warning pointed to the main file.
    But I think I found the error: As soon as there is a space within the path
    name, the included files are not correctly parsed.

    Alex

     

  • Anonymous
    2011-11-16

    Indeed. No spaces, no wrong warnings/errors.

     
  • t.schreiter
    t.schreiter
    2012-01-13

    Is there a workaround or bug fix coming up?

    Background: When using a company/university laptop, one is usually bound to a
    folder in My Documents, which contains a space and causes the bug.

     
  • It should be fixed, if you compile the svn version

     
  • t.schreiter
    t.schreiter
    2012-01-16

    That looks like a lot of work, since I have never done that. Probably I then
    have to install compilers and such, which is not so easy on my
    company/university computer.

    Might be easier to wait for your next official release.

    Good to know that the bug will be fixed.

     
  • t.schreiter
    t.schreiter
    2012-02-11

    Btw. the it works now with version 2.3.

    Thank you.

     
  • t.schreiter
    t.schreiter
    2012-02-20

    Correction: It works partially.

    I am writing a thesis, compiled of many files. In draft mode, the errors are
    indicated in the correct file. But in normal mode, it points to the main file,
    which is wrong.

    Any ideas?

     
  • I have an idea, stop using Latex .. I am constantly getting line 0 errors,
    Tex's way of politely telling me that it has no idea where the error occurred,
    and it is my obligation to sift through this 17,000 word document to find the
    single missing character that will make all right again. Latex in theory is
    fantastic, however in practise, at least on my Miktex setup in windows, is
    completely ridiculous.

    This is the first and last thing I will ever do in Latex