Auto close environment

Thiago
2014-05-23
2014-06-29
1 2 > >> (Page 1 of 2)
  • Thiago
    Thiago
    2014-05-23

    I'm using

    TeXstudio 2.7.1 (hg 9364)
    This is a development version.
    Using Qt Version 4.7.4, compiled with Qt 4.7.4 D

    and I don't know what had changed but I'm getting strange behavior when using auto closing environment.

    Let me explain: if I start to type \begin I can see a list of suggestions and I can choose one using mouse or keyboard.

    If I continue typing until \begin{ TeXstudio automatically close the brace and shows \begin{|} (where | is the cursor).

    On the last version I was using (a stable one) after { the list still were there and if I had typed \begin{tab for example, the suggestions were refined.

    Any idea?

     
    • Works fine here ?
      by the way, latest version is hg 4485

      Am 24.05.2014 01:21, schrieb Thiago:

      I'm using

      TeXstudio 2.7.1 (hg 9364)
      This is a development version.
      Using Qt Version 4.7.4, compiled with Qt 4.7.4 D

      and I don't know what had changed but I'm getting strange behavior when
      using auto closing environment.

      Let me explain: if I start to type |\begin| I can see a list of
      suggestions and I can choose one using mouse or keyboard.

      If I continue typing until |\begin{| TeXstudio automatically close the
      brace and shows |\begin{|}| (where | is the cursor).

      On the last version I was using (a stable one) after |{| the list still
      were there and if I had typed |\begin{tab| for example, the suggestions
      were refined.

      Any idea?


      Auto close environment
      https://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#1355


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/texstudio/discussion/907839/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

       
  • Thiago
    Thiago
    2014-05-24

    I had downloaded texstudio-hg-9364eb5ad1c97f1df4742897e5c45313613c20aa on 15 May. So I suppose that the number 4485 is from an older version, but maybe a stable one?

     
  • Tim Hoffmann
    Tim Hoffmann
    2014-05-25

    Actually, no. There are two version numbers in mercurial. One is the global revision number (i.e. 9364eb5ad1c97f1df4742897e5c45313613c20aa) which is globally unique. It's actually a hash value and may be abbreviated as long as it stays unique. The other is the local revision number of the repository (the 4485 Jan mentioned). The advantage of the local revision number is, that it is monotonically increased with every commit to a (local) repository, but strictly it's only valid there. The same commit may in principle have different local revision ids in different repositories, depending on their history. However, as long as you strictly synchronize (push/pull) with a common central repository, such as the TXS one on sf, also the local revision numbers remain synchronized.

    Your 9364eb5ad1c97f1df4742897e5c45313613c20aa has a local revision number of 4452 in my repository, so it's actually older than the one Jan mentioned.

    That said, I cannot reproduce your issue either. Have you changed any settings regarding completion? If not, could you checkout the most recent version and test with that?

     
  • Thiago
    Thiago
    2014-05-26

    Thanks everybody.

    I guess that I understood the idea behind the version numbers.

    Since I was not able to use mercurial I just downloaded the snapshot from here: https://sourceforge.net/p/texstudio/hg/ci/default/tree/

    But if some file is update today, for example, should I download everything again from the same link or every time a file is updated the link is also changed?

    Well, I'd like to use the newest version with minor changes (because some bugs take some time to be corrected on official releases, I guess).

    So what branch should I download? Stable? Default?

    About your question on some auto completion changes, I'm not using anything different from the older version. I just notices that some cwl files are not sorted correctly.

    See the image

    Thanks again.

     
    • Tim Hoffmann
      Tim Hoffmann
      2014-05-26

      every time a file is updated the link is also changed?

      Yes. However, I'd advise to use hg if you want to update more often. It's easier than always downloading the complete repo snapshot.

      If you want to have the newest features, go for the default branch. Be prepared, that this is a development state of the software, which contains the newest bugs as well. You are welcome to report these should you encounter one.

      The stable branch is intended for releases and bugfixes. But we currently don't have a strict update policy there (except before a release). It may be that bugs have been fixed in default, but not yet merged to stable.

      @Unsorted cwls:
      Looks sorted to me, though sorting seems to be case-sensitive. I don't know if this is desired or accidental.

       
      • Thiago
        Thiago
        2014-05-28

        Well, I got the stable snapshot and everything is fine. I am not able
        what was the problem with the default branch.

        Thanks.
        Thiago

        ps: congrats for the good job with TXS

        2014-05-26 18:39 GMT-03:00, Tim Hoffmann t_hoffmann@users.sf.net:

        every time a file is updated the link is also changed?

        Yes. However, I'd advise to use hg if you want to update more often. It's
        easier than always downloading the complete repo snapshot.

        If you want to have the newest features, go for the default branch. Be
        prepared, that this is a development state of the software, which contains
        the newest bugs as well. You are welcome to report these should you
        encounter one.

        The stable branch is intended for releases and bugfixes. But we currently
        don't have a strict update policy there (except before a release). It may be
        that bugs have been fixed in default, but not yet merged to stable.

        @Unsorted cwls:
        Looks sorted to me, though sorting seems to be case-sensitive. I don't know
        if this is desired or accidental.


        Auto close
        environment


        Sent from sourceforge.net because you indicated interest in
        https://sourceforge.net/p/texstudio/discussion/907839/

        To unsubscribe from further messages, please visit
        https://sourceforge.net/auth/subscriptions/

        --
        Thiago de Melo

         
        • Tim Hoffmann
          Tim Hoffmann
          2014-05-28

          But the default branch exhibited that behavior in your case? That would imply that the effect is caused by some recent changes and we would have to investigate that. Ohterwise it would be merged into stable on the next release.

           
          • Thiago
            Thiago
            2014-05-28

            Well, on Mai 16 I downloaded the snapshot

            texstudio-hg-45c776b8e7f98da7e21717e36b5e77779853cf25

            from default branch. So the problem had appeared.

            After our discussion I downloaded on Mai 26 the snapshot

            texstudio-hg-324980d6efc1c6ba1bb4c789a7a2d5c9ea2f7ae9

            from stable branch and now it is fine.

            But I have no idea what was the reason of the problem. If you wish I
            can try to test it again.

            Thanks.

            2014-05-28 15:34 GMT-03:00, Tim Hoffmann t_hoffmann@users.sf.net:

            But the default branch exhibited that behavior in your case? That would
            imply that the effect is caused by some recent changes and we would have to
            investigate that. Ohterwise it would be merged into stable on the next
            release.


            Auto close
            environment


            Sent from sourceforge.net because you indicated interest in
            https://sourceforge.net/p/texstudio/discussion/907839/

            To unsubscribe from further messages, please visit
            https://sourceforge.net/auth/subscriptions/

            --
            Thiago de Melo

             
  • Thiago
    Thiago
    2014-06-24

    Today I downloaded texstudio-hg-6e4aaf475c62f22adf1066a37c91c13187671941.zip from http://sourceforge.net/p/texstudio/hg/ci/stable/tree/ and now the problem came back.

    About shows TeXstudio 2.8.0 (hg n/a).

    Edit:
    I downloaded also the source for 2.8.0 released some days ago and the About shows TeXstudio 2.8.0 (hg 4553:dc1171a92ce0).

    But the same problem.

     
    Last edit: Thiago 2014-06-24
  • Tim Hoffmann
    Tim Hoffmann
    2014-06-25

    Works here, as far as I understood what you did. In between the three screenshots in the attachment, I just continued typing without any interaction. Was that what you did?

    Please try to describe even more exactly, what you do, what you would expect and what happens instead.

     
    Attachments
    • Thiago
      Thiago
      2014-06-25

      After typing \begin the list appears, OK, nice!

      But when I type the left brace, that is \begin{ automatically the
      right brace appears and the list is closed and the result is \begin{}
      with the cursor inside the braces {|}.

      I'd like to have the same effect as yours.

      Thanks for your help.

      2014-06-25 15:22 GMT-03:00, Tim Hoffmann t_hoffmann@users.sf.net:

      Works here, as far as I understood what you did. In between the three
      screenshots in the attachment, I just continued typing without any
      interaction. Was that what you did?

      Please try to describe even more exactly, what you do, what you would expect
      and what happens instead.

      Attachment: completion.png (13.7 kB; image/png)


      Auto close
      environment


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/texstudio/discussion/907839/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

      --
      Thiago de Melo

       
  • Tim Hoffmann
    Tim Hoffmann
    2014-06-25

    Can you please send your configuration (texstudio.ini) to me, so I can test with your settings? -> thoffmann@texstudio.org

     
    • it happens with "complete with non-word character" disabled !!!

      Am 25.06.2014 20:38, schrieb Tim Hoffmann:

      Can you please send your configuration (texstudio.ini) to me, so I can
      test with your settings? -> thoffmann@texstudio.org


      Auto close environment
      https://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/texstudio/discussion/907839/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

       
      • Thiago
        Thiago
        2014-06-25

        Yes Jan, you are right. I don't know why it was not selected but this
        solved my problem.

        Thanks so much. Best wishes.

        Thiago

        2014-06-25 18:45 GMT-03:00, Jan Sundermeyer jsundermeyer@users.sf.net:

        it happens with "complete with non-word character" disabled !!!

        Am 25.06.2014 20:38, schrieb Tim Hoffmann:

        Can you please send your configuration (texstudio.ini) to me, so I can
        test with your settings? -> thoffmann@texstudio.org


        Auto close environment
        https://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c


        Sent from sourceforge.net because you indicated interest in
        https://sourceforge.net/p/texstudio/discussion/907839/

        To unsubscribe from further messages, please visit
        https://sourceforge.net/auth/subscriptions/


        Auto close
        environment


        Sent from sourceforge.net because you indicated interest in
        https://sourceforge.net/p/texstudio/discussion/907839/

        To unsubscribe from further messages, please visit
        https://sourceforge.net/auth/subscriptions/

        --
        Thiago de Melo

         
        • The issue is fixed in default branch.

          Am 26.06.2014 00:01, schrieb Thiago:

          Yes Jan, you are right. I don't know why it was not selected but this
          solved my problem.

          Thanks so much. Best wishes.

          Thiago

          2014-06-25 18:45 GMT-03:00, Jan Sundermeyer jsundermeyer@users.sf.net
          jsundermeyer@users.sf.net:

          it happens with "complete with non-word character" disabled !!!
          
          Am 25.06.2014 20:38, schrieb Tim Hoffmann:
          
              Can you please send your configuration (texstudio.ini) to me, so
              I can
              test with your settings? -> thoffmann@texstudio.org
          
              ------------------------------------------------------------------------
          
              Auto close environment
              https://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c
          
              ------------------------------------------------------------------------
          
              Sent from sourceforge.net because you indicated interest in
              https://sourceforge.net/p/texstudio/discussion/907839/
          
              To unsubscribe from further messages, please visit
              https://sourceforge.net/auth/subscriptions/
          
          ------------------------------------------------------------------------
          
          Auto close
          environment
          <http://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c/3324>
          
          ------------------------------------------------------------------------
          
          Sent from sourceforge.net because you indicated interest in
          https://sourceforge.net/p/texstudio/discussion/907839/
          
          To unsubscribe from further messages, please visit
          https://sourceforge.net/auth/subscriptions/
          

          --
          Thiago de Melo


          Auto close environment
          http://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c/3324/e607


          Sent from sourceforge.net because you indicated interest in
          https://sourceforge.net/p/texstudio/discussion/907839/

          To unsubscribe from further messages, please visit
          https://sourceforge.net/auth/subscriptions/

           
          • Thiago
            Thiago
            2014-06-28

            Thanks. I've just got it.
            Congratulations for this great job. TeXstudio is the best editor.

            2014-06-28 14:39 GMT-03:00, Jan Sundermeyer jsundermeyer@users.sf.net:

            The issue is fixed in default branch.

            Am 26.06.2014 00:01, schrieb Thiago:

            Yes Jan, you are right. I don't know why it was not selected but this
            solved my problem.

            Thanks so much. Best wishes.

            Thiago

            2014-06-25 18:45 GMT-03:00, Jan Sundermeyer jsundermeyer@users.sf.net
            jsundermeyer@users.sf.net:

            it happens with "complete with non-word character" disabled !!!
            
            Am 25.06.2014 20:38, schrieb Tim Hoffmann:
            
                Can you please send your configuration (texstudio.ini) to me, so
                I can
                test with your settings? -> thoffmann@texstudio.org
            

                Auto close environment
            

            https://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c


                Sent from sourceforge.net because you indicated interest in
                https://sourceforge.net/p/texstudio/discussion/907839/
            
                To unsubscribe from further messages, please visit
                https://sourceforge.net/auth/subscriptions/
            

            Auto close
            environment
            

            http://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c/3324


            Sent from sourceforge.net because you indicated interest in
            https://sourceforge.net/p/texstudio/discussion/907839/
            
            To unsubscribe from further messages, please visit
            https://sourceforge.net/auth/subscriptions/
            

            --
            Thiago de Melo


            Auto close environment
            http://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c/3324/e607


            Sent from sourceforge.net because you indicated interest in
            https://sourceforge.net/p/texstudio/discussion/907839/

            To unsubscribe from further messages, please visit
            https://sourceforge.net/auth/subscriptions/


            Auto close
            environment


            Sent from sourceforge.net because you indicated interest in
            https://sourceforge.net/p/texstudio/discussion/907839/

            To unsubscribe from further messages, please visit
            https://sourceforge.net/auth/subscriptions/

            --
            Thiago de Melo

             
            • Thiago
              Thiago
              2014-06-28

              I got today the default branch.

              But something very strange is happening with completion.

              If I type [ to change to math mode to use [ .... ] for equations,
              TeXstudio completes with

              \ArrowBetweenLines[

              and opens the list of suggestions with only one suggestion:
              \ArrowBetweenLines[symbol]

              I don't know why. I just compiled it and installed. I had never seen
              that command.

              2014-06-28 16:46 GMT-03:00, Thiago tmelorc1@users.sf.net:

              Thanks. I've just got it.
              Congratulations for this great job. TeXstudio is the best editor.

              2014-06-28 14:39 GMT-03:00, Jan Sundermeyer jsundermeyer@users.sf.net:

              The issue is fixed in default branch.

              Am 26.06.2014 00:01, schrieb Thiago:

              Yes Jan, you are right. I don't know why it was not selected but this
              solved my problem.

              Thanks so much. Best wishes.

              Thiago

              2014-06-25 18:45 GMT-03:00, Jan Sundermeyer jsundermeyer@users.sf.net
              jsundermeyer@users.sf.net:

              it happens with "complete with non-word character" disabled !!!
              
              Am 25.06.2014 20:38, schrieb Tim Hoffmann:
              
                  Can you please send your configuration (texstudio.ini) to me, so
                  I can
                  test with your settings? -> thoffmann@texstudio.org
              

                  Auto close environment
              

              https://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c


                  Sent from sourceforge.net because you indicated interest in
                  https://sourceforge.net/p/texstudio/discussion/907839/
              
                  To unsubscribe from further messages, please visit
                  https://sourceforge.net/auth/subscriptions/
              

              Auto close
              environment
              

              http://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c/3324


              Sent from sourceforge.net because you indicated interest in
              https://sourceforge.net/p/texstudio/discussion/907839/
              
              To unsubscribe from further messages, please visit
              https://sourceforge.net/auth/subscriptions/
              

              --
              Thiago de Melo


              Auto close environment
              http://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c/3324/e607


              Sent from sourceforge.net because you indicated interest in
              https://sourceforge.net/p/texstudio/discussion/907839/

              To unsubscribe from further messages, please visit
              https://sourceforge.net/auth/subscriptions/


              Auto close
              environment


              Sent from sourceforge.net because you indicated interest in
              https://sourceforge.net/p/texstudio/discussion/907839/

              To unsubscribe from further messages, please visit
              https://sourceforge.net/auth/subscriptions/

              --
              Thiago de Melo


              Auto close
              environment


              Sent from sourceforge.net because you indicated interest in
              https://sourceforge.net/p/texstudio/discussion/907839/

              To unsubscribe from further messages, please visit
              https://sourceforge.net/auth/subscriptions/

              --
              Thiago de Melo

               
              • do you have complete with non-word character still activated ?

                Am 28.06.2014 22:33, schrieb Thiago:

                I got today the default branch.

                But something very strange is happening with completion.

                If I type [ to change to math mode to use [ .... ] for equations,
                TeXstudio completes with

                \ArrowBetweenLines[

                and opens the list of suggestions with only one suggestion:
                \ArrowBetweenLines[symbol]

                I don't know why. I just compiled it and installed. I had never seen
                that command.

                2014-06-28 16:46 GMT-03:00, Thiago tmelorc1@users.sf.net
                tmelorc1@users.sf.net:

                Thanks. I've just got it.
                Congratulations for this great job. TeXstudio is the best editor.
                
                2014-06-28 14:39 GMT-03:00, Jan Sundermeyer
                jsundermeyer@users.sf.net <mailto:jsundermeyer@users.sf.net>:
                
                    The issue is fixed in default branch.
                
                    Am 26.06.2014 00:01, schrieb Thiago:
                
                        Yes Jan, you are right. I don't know why it was not selected
                        but this
                        solved my problem.
                
                        Thanks so much. Best wishes.
                
                        Thiago
                
                        2014-06-25 18:45 GMT-03:00, Jan Sundermeyer
                        jsundermeyer@users.sf.net
                        jsundermeyer@users.sf.net <mailto:jsundermeyer@users.sf.net>:
                
                        it happens with "complete with non-word character" disabled !!!
                
                        Am 25.06.2014 20:38, schrieb Tim Hoffmann:
                
                            Can you please send your configuration (texstudio.ini) to me, so
                            I can
                            test with your settings? -> thoffmann@texstudio.org
                
                        ------------------------------------------------------------------------
                
                            Auto close environment
                
                        https://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c
                
                        ------------------------------------------------------------------------
                
                            Sent from sourceforge.net because you indicated interest in
                            https://sourceforge.net/p/texstudio/discussion/907839/
                
                            To unsubscribe from further messages, please visit
                            https://sourceforge.net/auth/subscriptions/
                
                        ------------------------------------------------------------------------
                
                        Auto close
                        environment
                
                        http://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c/3324
                
                        ------------------------------------------------------------------------
                
                        Sent from sourceforge.net because you indicated interest in
                        https://sourceforge.net/p/texstudio/discussion/907839/
                
                        To unsubscribe from further messages, please visit
                        https://sourceforge.net/auth/subscriptions/
                
                        --
                        Thiago de Melo
                
                        ------------------------------------------------------------------------
                
                        Auto close environment
                        http://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c/3324/e607
                
                        ------------------------------------------------------------------------
                
                        Sent from sourceforge.net because you indicated interest in
                        https://sourceforge.net/p/texstudio/discussion/907839/
                
                        To unsubscribe from further messages, please visit
                        https://sourceforge.net/auth/subscriptions/
                
                    ------------------------------------------------------------------------
                
                    Auto close
                    environment
                    <http://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c/3324/e607/f6c8>
                
                    ------------------------------------------------------------------------
                
                    Sent from sourceforge.net because you indicated interest in
                    https://sourceforge.net/p/texstudio/discussion/907839/
                
                    To unsubscribe from further messages, please visit
                    https://sourceforge.net/auth/subscriptions/
                
                --
                Thiago de Melo
                
                ------------------------------------------------------------------------
                
                Auto close
                environment
                <http://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c/3324/e607/f6c8/585d>
                
                ------------------------------------------------------------------------
                
                Sent from sourceforge.net because you indicated interest in
                https://sourceforge.net/p/texstudio/discussion/907839/
                
                To unsubscribe from further messages, please visit
                https://sourceforge.net/auth/subscriptions/
                

                --
                Thiago de Melo


                Auto close environment
                http://sourceforge.net/p/texstudio/discussion/907839/thread/8cd05a92/?limit=25#172c/3324/e607/f6c8/585d/14c3


                Sent from sourceforge.net because you indicated interest in
                https://sourceforge.net/p/texstudio/discussion/907839/

                To unsubscribe from further messages, please visit
                https://sourceforge.net/auth/subscriptions/

                 
1 2 > >> (Page 1 of 2)