#654 Multiple pop-up warning windows

None
closed
nobody
None
1
2013-10-13
2012-12-05
Denis Bitouzé
No

At some point of a (re)compilation process of a .tex file, if the
embedded viewer is open, a warning appears in a pop-up window
containing:

...
does not look like a valid PDF document.

Either the file is corrupt or it is in the process of creation. You
may retry after compilation is finished. Opening a corrupt document
could cause a crash. Do you want to open it anyway?

So far, so good¹. But, at least on Linux, if the process is long
enough, multiple windows, all with the same warn message, appear (for
instance, 18 windows for a 60 pages document compiled with
latexmk). This is useless and very annoying.

IMHO, TXS should check if such a windows is already open and, if so,
not open new one(s).


¹I'm not sure pop-up windows are necessary here: a message displayed
in the PDF viewer area should be enough.

Related

Bugs: #654

Discussion

1 2 > >> (Page 1 of 2)
  • Tim Hoffmann
    Tim Hoffmann
    2012-12-05

    which version of TXS do you use?

     
  • Denis Bitouzé
    Denis Bitouzé
    2012-12-05

    TeXstudio 2.5.1 (SVN 3484)
    Using Qt Version 4.8.2, compiled with Qt 4.8.2 D

     
  • Tim Hoffmann
    Tim Hoffmann
    2012-12-05

    Does it happen everytime? Does it only happen with latexmk or also with a single pdflatex call or when using the internal build system?

     
  • Denis Bitouzé
    Denis Bitouzé
    2012-12-05

    It happens also with a single xelatex call.

     
  • Tim Hoffmann
    Tim Hoffmann
    2012-12-05

    I cannot reproduce it (Ubuntu, TXS rev. 3546, xelatex)

    can you provide your profile?

     
  • Denis Bitouzé
    Denis Bitouzé
    2012-12-06

    My Linux box is Mageia 2. My .ini file is attached.

     
    Attachments
  • Tim Hoffmann
    Tim Hoffmann
    2012-12-09

    • status: open --> closed
    • milestone: -->
     
  • Tim Hoffmann
    Tim Hoffmann
    2012-12-09

    fixed in rev. 3559

     
  • Sorry for opening this issue again, but on Mac OS X 10.8.4 (Mountain Lion) whenever a PDF takes a long time to compile with XeLaTeX (because of shell escape calling Python scripts which export SVGs to PDF+LaTeX using Inkscape), multiple pop-ups amass.

    It has been a pain for about 2 years now. Recalling how easy it was 4 years ago to use TeXstudio (when it lacked this warning), I would like an option to switch it off completely.

    Recognizing no check at all is not so desirable for the app's stability, eventually I came up with a suggestion. Please consider providing the following option. When you are in the editor's window (PDF preview open) and start compiling, the previewer detects an incomplete PDF. Instead of delaying and then asking whether to load it, there is a better solution. Show a single warning message in the previewer only (i.e., don't steal window focus) and continue checking periodically. If the PDF looks sane at some point, load it and automatically close the warning. Otherwise, if the user switches to the previewer while the warning is present, perceive that as an "OK, load it, I've seen the warning".

     
  • How do you start xelatex ?
    Actually all warnings should be suppressed during compiling (which was
    started by txs).

    On 21.09.2013 23:27, Ioannis Filippidis wrote:

    Sorry for opening this issue again, but on Mac OS X 10.8.4 (Mountain
    Lion) whenever a |PDF| takes a long time to compile with |XeLaTeX|
    (because of shell escape calling Python scripts which export |SVG|s to
    |PDF|+|LaTeX| using Inkscape), multiple pop-ups amass.

    It has been a pain for about 2 years now. Recalling how easy it was 4
    years ago to use TeXstudio (when it lacked this warning), I would like
    an option to switch it off completely.

    Recognizing no check at all is not so desirable for the app's stability,
    eventually I came up with a suggestion. Please consider providing the
    following option. When you are in the editor's window (PDF preview open)
    and start compiling, the previewer detects an incomplete |PDF|. Instead
    of delaying and then asking whether to load it, there is a better
    solution. Show a single warning message in the previewer only (i.e.,
    don't steal window focus) and continue checking periodically. If the
    |PDF| looks sane at some point, load it and automatically close the
    warning. Otherwise, if the user switches to the previewer while the
    warning is present, perceive that as an "OK, load it, I've seen the
    warning".


    [bugs:#654] http://sourceforge.net/p/texstudio/bugs/654/ Multiple
    pop-up warning windows

    Status: closed
    Created: Wed Dec 05, 2012 12:34 PM UTC by Denis Bitouzé
    Last Updated: Sun Dec 09, 2012 04:15 PM UTC
    Owner: nobody

    At some point of a (re)compilation process of a .tex file, if the
    embedded viewer is open, a warning appears in a pop-up window
    containing:

    ...
    does not look like a valid PDF document.

    Either the file is corrupt or it is in the process of creation. You
    may retry after compilation is finished. Opening a corrupt document
    could cause a crash. Do you want to open it anyway?

    So far, so good¹. But, at least on Linux, if the process is long
    enough, multiple windows, all with the same warn message, appear (for
    instance, 18 windows for a 60 pages document compiled with
    latexmk). This is useless and very annoying.

    IMHO, TXS should check if such a windows is already open and, if so,
    not open new one(s).


    ¹I'm not sure pop-up windows are necessary here: a message displayed
    in the PDF viewer area should be enough.


    Sent from sourceforge.net because you indicated interest in
    https://sourceforge.net/p/texstudio/bugs/654/

    To unsubscribe from further messages, please visit
    https://sourceforge.net/auth/subscriptions/

     

    Related

    Bugs: #654

1 2 > >> (Page 1 of 2)