Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#1266 Import of Output Profiles does not work

None
closed
nobody
5
2013-07-04
2012-02-20
Anonymous
No

When attempting to import the output profiles from Version 2 Alpha 3 in Alpha 4 (32 or 64bit), TeXnicCenter complains about the Microsoft XML Parser not being properly installed. The import worked in Alpha 3. When importing profiles exported from Alpha 4 in Alpha 4 and error is reported for the xml.

Discussion


  • Anonymous
    2012-02-22

    Hello, I can tell you I have the same problem. I have a solution for 32 bits version. The file OutputProfiles.xsd into TexnicCenter folder has an error. I corrected it and posted the same error as you at http://www.latex-community.org/forum/viewtopic.php?f=31&t=17908. Download the file and try it.
    Please, test it and tell me about the solution. The file doesn't work for 64 bits version. There's a bug in the app. It calls a non existent address (I debugged it!) but I can't solve it (I can't program in MFC).
    PauloH

     
    Last edit: Anonymous 2014-05-10
  • Marcel
    Marcel
    2012-05-24

    I can tell you the solution:

    If you open your program folder you will see a file named:

    "OutputProfiles.xsd"

    This file defines the xml structure of the file you wish to import.
    Open it with an editor like np++ and do the following:

    Search for this line: <!-- definition of a single output profile
    (identified by name) -->

    Copy the following code and paste it above the postProcessor element. It's
    almost the same just "post" replaced by "pre". But because this is missing
    in the expecting structure but listed in the file you wish to import you're
    getting the error message.

    <xs:element name="preProcessors" type="ProcessorList">
    <xs:unique name="preProcessorNames">
    <xs:selector xpath="processor" />
    <xs:field xpath="@name" />
    </xs:unique>
    </xs:element>

    Now save the file.
    Everything should be fine now.

    Happy TeXing
    Marcel

     
  • Tino Weinkauf
    Tino Weinkauf
    2012-11-03

    Thanks for your report. We already fixed that bug. The changes will be in the next release.

     


Anonymous


Cancel   Add attachments